summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjszczerbinsky2022-06-30 14:23:39 +0000
committerjszczerbinsky2022-06-30 14:23:39 +0000
commit039adda8de533f6312ad28d4cdef2cf60ced6ac4 (patch)
treec76183f7a59445e9ab184d44fdfcdb3ef11c5a99
downloadaur-ptsh.tar.gz
init
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD34
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..faf2b6424133
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = ptsh
+ pkgdesc = Visually customizable shell utils
+ pkgver = 0.4
+ pkgrel = 1
+ url = https://github.com/jszczerbinsky/ptSh
+ arch = any
+ license = MIT
+ source = https://github.com/jszczerbinsky/ptSh/archive/refs/tags/v0.4.tar.gz
+ sha256sums = 7c37a88056d6270b25b79db07c6a3828fefd42c8b57660f9b6a1f65b0d76c5bf
+
+pkgname = ptsh
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d9dc04ee9542
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Jakub SzczerbiƄski <jszczerbinsky2@gmail.com>
+pkgname=ptsh
+pkgver=0.4
+pkgrel=1
+pkgdesc="Visually customizable shell utils"
+arch=('any')
+url="https://github.com/jszczerbinsky/ptSh"
+license=('MIT')
+groups=()
+depends=()
+makedepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/jszczerbinsky/ptSh/archive/refs/tags/v${pkgver//_/-}.tar.gz")
+noextract=()
+sha256sums=('7c37a88056d6270b25b79db07c6a3828fefd42c8b57660f9b6a1f65b0d76c5bf')
+
+build() {
+ cd "ptSh-${pkgver//_/-}"
+ make
+}
+
+package() {
+ mkdir -p "$pkgdir/usr"
+ cd "ptSh-${pkgver//_/-}"
+ make DESTDIR="$pkgdir/" install
+ echo "Version: v$pkgver" > "$pkgdir/usr/share/ptSh/version.txt"
+}