summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjonian2022-11-07 23:11:16 +0200
committerjonian2022-11-07 23:11:16 +0200
commit745d6d2efd23850e78478b4ab25dc926c45807b3 (patch)
treeca7c7228068feb43cfa49e93ca3d9538be9f051d
parente76cd75315e2ce18b0d0047346b1da89b12e4870 (diff)
downloadaur-745d6d2efd23850e78478b4ab25dc926c45807b3.tar.gz
use latest build from master, fix github package
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD15
2 files changed, 16 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a11f556def07..e6cf6c4c02c9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = pulsar-bin
pkgdesc = Community build of the hackable text editor, built on Electron
- pkgver = 1.63.2022110709
- pkgrel = 2
+ pkgver = 1.63.2022110702
+ pkgrel = 1
url = https://github.com/pulsar-edit/pulsar
arch = x86_64
license = MIT
+ makedepends = asar
depends = libxkbfile
depends = ripgrep
optdepends = ctags: symbol indexing support
@@ -12,7 +13,7 @@ pkgbase = pulsar-bin
optdepends = hunspell: spell check integration
provides = pulsar
conflicts = pulsar
- source = pulsar-1.63.2022110709.deb::https://api.cirrus-ci.com/v1/artifact/task/5872488717484032/binary/binaries/pulsar_1.63.2022110709_amd64.deb
- sha256sums = bf1692bd10e47a78ac810d4dce09d2894bcf6ec9b0b79647e308c1d7b70fd951
+ source = pulsar-1.63.2022110702.deb::https://api.cirrus-ci.com/v1/artifact/task/5999796983955456/binary/binaries/pulsar_1.63.2022110702_amd64.deb
+ sha256sums = 8f7500fb0928390c64d61ad4f78cc4683de912bb47213875ea18f4a1794cd8f3
pkgname = pulsar-bin
diff --git a/PKGBUILD b/PKGBUILD
index ec8298e42e46..4fabbc828548 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,18 @@
_appname=pulsar
_reponame=pulsar-edit
-_tasktag=5872488717484032
-_datetag=2022110709
+_tasktag=5999796983955456
+_datetag=2022110702
pkgname="${_appname}-bin"
pkgver="1.63.${_datetag}"
-pkgrel=2
+pkgrel=1
pkgdesc="Community build of the hackable text editor, built on Electron"
arch=("x86_64")
url="https://github.com/${_reponame}/${_appname}"
license=("MIT")
depends=("libxkbfile" "ripgrep")
+makedepends=("asar")
optdepends=(
"ctags: symbol indexing support"
"git: Git and GitHub integration"
@@ -22,16 +23,22 @@ optdepends=(
provides=("${_appname}")
conflicts=("${_appname}")
source=("${_appname}-${pkgver}.deb::https://api.cirrus-ci.com/v1/artifact/task/${_tasktag}/binary/binaries/${_appname}_${pkgver}_amd64.deb")
-sha256sums=('bf1692bd10e47a78ac810d4dce09d2894bcf6ec9b0b79647e308c1d7b70fd951')
+sha256sums=('8f7500fb0928390c64d61ad4f78cc4683de912bb47213875ea18f4a1794cd8f3')
prepare() {
bsdtar xf data.tar.xz
+ asar e opt/Pulsar/resources/app.asar asar
}
package() {
mv opt "$pkgdir"
mv usr "$pkgdir"
+ # This needs removal along with asar makedepend when fixed upstream
+ mkdir -p "$pkgdir/opt/Pulsar/resources/app.asar.unpacked/node_modules/github/"
+ mv asar/node_modules/github/bin "$pkgdir/opt/Pulsar/resources/app.asar.unpacked/node_modules/github/bin"
+ rm -rf asar
+
mkdir -p "$pkgdir/usr/bin"
chmod +x "$pkgdir/opt/Pulsar/resources/${_appname}.sh"