summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjonian2022-11-13 15:57:51 +0200
committerjonian2022-11-13 15:57:51 +0200
commit8a3b819bc89aa28dc22457f4125c898e621c0859 (patch)
tree42357ec18d750e3b6b096f6e7b2a90ce1671449f
parentdcc0904f52d53b5f314be35a4e119d9ad5b9e1ae (diff)
downloadaur-8a3b819bc89aa28dc22457f4125c898e621c0859.tar.gz
optimize bug fixes
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ac9e2e2103c1..9ea8f8e9a361 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pulsar-bin
pkgdesc = Community build of the hackable text editor, built on Electron
pkgver = 1.63.2022111116
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/pulsar-edit/pulsar
arch = x86_64
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index b15cab5ce25e..b19bb91323b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ _datetag=2022111116
pkgname="${_appname}-bin"
pkgver="1.63.${_datetag}"
-pkgrel=3
+pkgrel=4
pkgdesc="Community build of the hackable text editor, built on Electron"
arch=("x86_64")
url="https://github.com/${_reponame}/${_appname}"
@@ -40,11 +40,15 @@ package() {
# Fix core modules missing in settings. Remove when implemented upstream
sed -i "s/=== 'apm'/=== 'ppm'/" "$pkgdir/opt/Pulsar/resources/app/ppm/lib/apm.js"
+ sed -i "s/is 'apm'/is 'ppm'/" "$pkgdir/opt/Pulsar/resources/app/ppm/src/apm.coffee"
# Fix featured not working. Remove when implemented upstream
sed -i "/pack != null/c return pack != null && pack.releases != null;" \
"$pkgdir/opt/Pulsar/resources/app/ppm/lib/featured.js"
+ sed -i "s/pack?.releases?.latest?/pack?.releases?/" \
+ "$pkgdir/opt/Pulsar/resources/app/ppm/src/featured.coffee"
+
# This needs removal along with asar makedepend when fixed upstream
mkdir -p "$pkgdir/opt/Pulsar/resources/app.asar.unpacked/node_modules/github/"
mv asar/node_modules/github/bin "$pkgdir/opt/Pulsar/resources/app.asar.unpacked/node_modules/github/bin"