summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjonian2022-11-07 15:13:01 +0200
committerjonian2022-11-07 15:13:01 +0200
commitbbe96d2b50c729cea9069c86a9239a896121ef0e (patch)
treebbeadb899f57a6be70f947af90bc1ce41aee304f
downloadaur-bbe96d2b50c729cea9069c86a9239a896121ef0e.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD37
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..559cbb65dec2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = pulsar-bin
+ pkgdesc = Community build of the hackable text editor, built on Electron
+ pkgver = 1.63.2022110709
+ pkgrel = 1
+ url = https://github.com/pulsar-edit/pulsar
+ arch = x86_64
+ license = MIT
+ depends = libxkbfile
+ depends = ripgrep
+ optdepends = ctags: symbol indexing support
+ optdepends = git: Git and GitHub integration
+ optdepends = hunspell: spell check integration
+ provides = pulsar
+ conflicts = pulsar
+ source = pulsar-1.63.2022110709.deb::https://api.cirrus-ci.com/v1/artifact/task/5872488717484032/binary/binaries/pulsar_1.63.2022110709_amd64.deb
+ sha256sums = bf1692bd10e47a78ac810d4dce09d2894bcf6ec9b0b79647e308c1d7b70fd951
+
+pkgname = pulsar-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..88c8256e8a33
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Jonian Guveli <jonian@hardpixel.eu>
+# Contributor: Giusy Digital <kurmikon@libero.it>
+
+_appname=pulsar
+_reponame=pulsar-edit
+_tasktag=5872488717484032
+_datetag=2022110709
+
+pkgname="${_appname}-bin"
+pkgver="1.63.${_datetag}"
+pkgrel=1
+pkgdesc="Community build of the hackable text editor, built on Electron"
+arch=("x86_64")
+url="https://github.com/${_reponame}/${_appname}"
+license=("MIT")
+depends=("libxkbfile" "ripgrep")
+optdepends=(
+ "ctags: symbol indexing support"
+ "git: Git and GitHub integration"
+ "hunspell: spell check integration"
+)
+provides=("${_appname}")
+conflicts=("${_appname}")
+source=("${_appname}-${pkgver}.deb::https://api.cirrus-ci.com/v1/artifact/task/${_tasktag}/binary/binaries/${_appname}_${pkgver}_amd64.deb")
+sha256sums=('bf1692bd10e47a78ac810d4dce09d2894bcf6ec9b0b79647e308c1d7b70fd951')
+
+prepare() {
+ bsdtar xf data.tar.xz
+}
+
+package() {
+ mv opt "$pkgdir"
+ mv usr "$pkgdir"
+
+ mkdir -p "$pkgdir/usr/bin"
+ ln -sf "/opt/Pulsar/${_appname}" "$pkgdir/usr/bin/${_appname}"
+}