summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjonian2022-11-13 15:03:15 +0200
committerjonian2022-11-13 15:03:15 +0200
commitdcc0904f52d53b5f314be35a4e119d9ad5b9e1ae (patch)
treebd254434df99d8bf477d8201c70f1ba35660ec0e
parent04070a1fd40f1fe60434e501a9d79b40773c356e (diff)
downloadaur-dcc0904f52d53b5f314be35a4e119d9ad5b9e1ae.tar.gz
fix featured packages not loading
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f18d2d2b52d3..ac9e2e2103c1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pulsar-bin
pkgdesc = Community build of the hackable text editor, built on Electron
pkgver = 1.63.2022111116
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/pulsar-edit/pulsar
arch = x86_64
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 71a388b54e8f..b15cab5ce25e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ _datetag=2022111116
pkgname="${_appname}-bin"
pkgver="1.63.${_datetag}"
-pkgrel=2
+pkgrel=3
pkgdesc="Community build of the hackable text editor, built on Electron"
arch=("x86_64")
url="https://github.com/${_reponame}/${_appname}"
@@ -41,6 +41,10 @@ package() {
# Fix core modules missing in settings. Remove when implemented upstream
sed -i "s/=== 'apm'/=== 'ppm'/" "$pkgdir/opt/Pulsar/resources/app/ppm/lib/apm.js"
+ # Fix featured not working. Remove when implemented upstream
+ sed -i "/pack != null/c return pack != null && pack.releases != null;" \
+ "$pkgdir/opt/Pulsar/resources/app/ppm/lib/featured.js"
+
# This needs removal along with asar makedepend when fixed upstream
mkdir -p "$pkgdir/opt/Pulsar/resources/app.asar.unpacked/node_modules/github/"
mv asar/node_modules/github/bin "$pkgdir/opt/Pulsar/resources/app.asar.unpacked/node_modules/github/bin"