summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMoritz Lipp2015-06-15 20:18:10 +0200
committerMoritz Lipp2015-06-15 20:18:10 +0200
commitcfd331073747bbc03f47b9a3a6dd03fa0b88f2f8 (patch)
treeb83cc68fc07bcf4ff3025950ea64f8a4255438d9
downloadaur-pulse-bin.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6a8e6b08a2d4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = pulse-bin
+ pkgdesc = Synchronise your files without also sharing them with a stranger in the cloud.
+ pkgver = 0.1.3
+ pkgrel = 1
+ url = https://ind.ie/pulse/
+ arch = x86_64
+ arch = i686
+ license = GPL
+ makedepends = sed
+ makedepends = pacman-git
+ source_x86_64 = http://s3-eu-west-1.amazonaws.com/download.ind.ie/pulse/latest/pulse-linux-amd64-0.1.3.tar.gz
+ md5sums_x86_64 = e1078c5e0dea7cc7ec41365cdb57cd99
+ source_i686 = http://s3-eu-west-1.amazonaws.com/download.ind.ie/pulse/latest/pulse-linux-386-0.1.3.tar.gz
+ md5sums_i686 = f6c4baa9e6ba92a5539e93a7cbc1c05f
+
+pkgname = pulse-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f207a30a2cfa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Moritz Lipp <mail@mlq.me>
+pkgname=pulse-bin
+_pkgname=pulse
+pkgver=0.1.3
+pkgrel=1
+pkgdesc="Synchronise your files without also sharing them with a stranger in the
+cloud."
+arch=('x86_64' 'i686')
+url="https://ind.ie/pulse/"
+license=('GPL')
+makedepends=('sed' 'pacman-git')
+source_x86_64=("http://s3-eu-west-1.amazonaws.com/download.ind.ie/$_pkgname/latest/$_pkgname-linux-amd64-$pkgver.tar.gz")
+source_i686=("http://s3-eu-west-1.amazonaws.com/download.ind.ie/$_pkgname/latest/$_pkgname-linux-386-$pkgver.tar.gz")
+md5sums_x86_64=('e1078c5e0dea7cc7ec41365cdb57cd99')
+md5sums_i686=('f6c4baa9e6ba92a5539e93a7cbc1c05f')
+
+package() {
+ ARCH=`echo $arch | sed 's/x86_64/amd64/g;s/i686/386/g'`
+ cd "$srcdir/$_pkgname-linux-$ARCH-$pkgver/"
+ install -D -m777 pulse "$pkgdir/usr/bin/pulse"
+ install -D -m664 LICENSE.txt "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: