summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJat2024-04-23 16:40:08 +0800
committerJat2024-04-23 16:40:08 +0800
commita7ad97fc23d15d522098827417730dc81ebcf7b2 (patch)
tree1c0ace94fd09707969435870084a12eb105df961
parent91e53c8efa98b8e552127827ffe5a56caaf61c47 (diff)
downloadaur-pulseaudio-module-xrdp.tar.gz
Update PKGBUILD for pulseaudio-module-xrdp to expand architecture support, update license, and bump PulseAudio version dependency
Signed-off-by: Jat <jat@sinosky.org>
-rw-r--r--PKGBUILD22
1 files changed, 13 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2b3ad64377a3..c4df8beaac6e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,21 +3,25 @@
pkgname='pulseaudio-module-xrdp'
pkgver='0.7'
pkgrel='1'
-pkgdesc='PulseAudio modules for xrdp'
-arch=('i686' 'x86_64')
+pkgdesc='PulseAudio modules for xrdp.'
+arch=('i686' 'x86_64' 'armv6h' 'armv7l' 'aarch64')
url="https://github.com/neutrinolabs/pulseaudio-module-xrdp"
-license=('LGPL')
+license=('LGPL-2.1')
depends=('pulseaudio' 'xrdp')
makedepends=('meson' 'check' 'doxygen' 'perl-xml-parser')
install="${pkgname}.install"
_pulseaudio_ver="$(pulseaudio --version | awk '{print $NF}')"
-: "${_pulseaudio_ver:=16.1}"
-
-source=("${url}/archive/refs/tags/v${pkgver}.tar.gz"
- "https://freedesktop.org/software/pulseaudio/releases/pulseaudio-${_pulseaudio_ver}.tar.xz")
-sha256sums=('be101538ebe891bd4ae9d533559b99cf07abf0bbce399f50f2d248f35c160a9d'
- "$(curl -fs "${source[1]}.sha256sum" | awk '{print $1}')")
+: "${_pulseaudio_ver:=17.0}"
+
+source=(
+ "${url}/archive/refs/tags/v${pkgver}.tar.gz"
+ "https://freedesktop.org/software/pulseaudio/releases/pulseaudio-${_pulseaudio_ver}.tar.xz"
+)
+sha256sums=(
+ 'be101538ebe891bd4ae9d533559b99cf07abf0bbce399f50f2d248f35c160a9d'
+ "$(curl -fs "${source[1]}.sha256sum" | awk '{print $1}')"
+)
prepare() {
cd "${srcdir}/pulseaudio-${_pulseaudio_ver}"