summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoão Figueiredo2021-02-03 22:38:49 +0000
committerJoão Figueiredo2021-02-03 22:38:49 +0000
commit82848686c624299f1fa95cf503b24a164e0a4bbc (patch)
tree05f8b2ce661a90b477f044f99dedf72a39d84e20
parent51f16a5442b56dc31042e7fe5f166101277d5109 (diff)
downloadaur-82848686c624299f1fa95cf503b24a164e0a4bbc.tar.gz
Update to 4.8.4
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
2 files changed, 14 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a96be47644bc..6341c4ec2c83 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pulseeffects-legacy
pkgdesc = Audio Effects for Pulseaudio Applications, without pipewire
- pkgver = 4.8.3
- pkgrel = 3
+ pkgver = 4.8.4
+ pkgrel = 1
url = https://github.com/wwmm/pulseeffects
arch = x86_64
license = GPL3
@@ -32,8 +32,10 @@ pkgbase = pulseeffects-legacy
optdepends = yelp: help documentation
provides = pulseeffects
conflicts = pulseeffects
- source = pulseeffects-4.8.3.tar.gz::https://github.com/wwmm/pulseeffects/archive/v4.8.3.tar.gz
- sha256sums = c1c1c82ec68baa0d4e44a49b494af1f9e3093f2e62590b3561bff5566048ba56
+ source = pulseeffects-4.8.4.tar.gz::https://github.com/wwmm/pulseeffects/archive/v4.8.4.tar.gz
+ source = https://raw.githubusercontent.com/wwmm/pulseeffects/7c570c6e1354adedf01f7ba1e8fbe063cfc15ff2/data/pulseeffects.svg
+ sha256sums = 12ba3205025d815a747b58636861594f7d1e43a578a5b0411f7794f4c12e5d86
+ sha256sums = f9167f96246879eecd907a504b0a70050dc4d90fa520c556c813336974754350
pkgname = pulseeffects-legacy
diff --git a/PKGBUILD b/PKGBUILD
index 18a0d57dc8db..e4110c6afacc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: Wellington <wellingtonwallace@gmail.com>
pkgname=pulseeffects-legacy
-pkgver=4.8.3
-pkgrel=3
+pkgver=4.8.4
+pkgrel=1
pkgdesc="Audio Effects for Pulseaudio Applications, without pipewire"
arch=($CARCH)
url='https://github.com/wwmm/pulseeffects'
@@ -12,19 +12,20 @@ license=(GPL3)
depends=(gtk3 gtkmm3 glibmm libpulse gstreamer gst-plugin-gtk gst-plugins-bad
lilv boost-libs libsigc++ libsndfile libsamplerate zita-convolver libebur128
calf lsp-plugins rubberband librnnoise)
-makedepends=(meson boost itstool appstream-glib
- zam-plugins)
+makedepends=(meson boost itstool appstream-glib zam-plugins)
optdepends=('zam-plugins: maximizer'
'yelp: help documentation')
conflicts=(pulseeffects)
provides=(pulseeffects)
-source=("${pkgname%-*}-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('c1c1c82ec68baa0d4e44a49b494af1f9e3093f2e62590b3561bff5566048ba56')
+source=("${pkgname%-*}-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
+ "https://raw.githubusercontent.com/wwmm/pulseeffects/7c570c6e1354adedf01f7ba1e8fbe063cfc15ff2/data/pulseeffects.svg")
+sha256sums=('12ba3205025d815a747b58636861594f7d1e43a578a5b0411f7794f4c12e5d86'
+ 'f9167f96246879eecd907a504b0a70050dc4d90fa520c556c813336974754350')
prepare() {
## Fix SVG rendering issue in Qt environments (https://github.com/wwmm/pulseeffects/issues/867)
if [[ -e /usr/bin/qmake ]]; then
- curl https://raw.githubusercontent.com/wwmm/pulseeffects/7c570c6e1354adedf01f7ba1e8fbe063cfc15ff2/data/pulseeffects.svg -o ${pkgname%-*}-$pkgver/data/pulseeffects.svg
+ cp ../pulseeffects.svg ${pkgname%-*}-$pkgver/data/
fi
}