summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12022-09-26 00:37:07 +0800
committerChocobo12022-09-26 00:45:17 +0800
commitad792cb4d1940978b397de0470b051531023645b (patch)
treeabb876718362eea905ef51d1ecc902e565d0e1c1
downloadaur-ad792cb4d1940978b397de0470b051531023645b.tar.gz
newpkg: pv-git 1.6.20.r6.ga9cef81-1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD47
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..306c934b86d5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = pv-git
+ pkgdesc = Pipe Viewer is a terminal-based tool for monitoring the progress of data through a pipeline
+ pkgver = 1.6.20.r6.ga9cef81
+ pkgrel = 1
+ url = https://www.ivarch.com/programs/pv.shtml
+ arch = i686
+ arch = x86_64
+ license = custom:Artistic 2.0
+ makedepends = git
+ depends = glibc
+ provides = pv=1.6.20.r6.ga9cef81
+ conflicts = pv
+ source = git+https://github.com/a-j-wood/pv.git
+ sha256sums = SKIP
+
+pkgname = pv-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cd87b7e146da
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=pv-git
+pkgver=1.6.20.r6.ga9cef81
+pkgrel=1
+pkgdesc="Pipe Viewer is a terminal-based tool for monitoring the progress of data through a pipeline"
+arch=('i686' 'x86_64')
+url="https://www.ivarch.com/programs/pv.shtml"
+license=('custom:Artistic 2.0')
+depends=('glibc')
+makedepends=('git')
+provides=("pv=$pkgver")
+conflicts=('pv')
+source=("git+https://github.com/a-j-wood/pv.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "pv"
+
+ _tag=$(git tag -l --sort -v:refname | sed '/rc[0-9]*/d' | head -n1)
+ _rev=$(git rev-list --count $_tag..HEAD)
+ _hash=$(git rev-parse --short HEAD)
+ printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash" | sed 's/^v//'
+}
+
+build() {
+ cd "pv"
+
+ ./generate.sh
+ ./configure \
+ --prefix="/usr"
+ make
+}
+
+check() {
+ cd "pv"
+
+ make check
+}
+
+package() {
+ cd "pv"
+
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "doc/COPYING" -t "$pkgdir/usr/share/licenses/pv"
+}