summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornot_anonymous2017-02-15 12:17:45 -0700
committernot_anonymous2017-02-15 12:17:45 -0700
commit3eb2b79fd04ad1b36f4e9ddd8e14027222f54de7 (patch)
tree323bee07b37d2fb63442fdc995b6e9e71985d4ea
parentba97c7be0b4596ccc1461690f4afef44aa33fa89 (diff)
downloadaur-pydxcluster.tar.gz
Updated
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
-rw-r--r--pydxcluster.16
3 files changed, 16 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 04cf239f654c..c098a3901f1e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
pkgbase = pydxcluster
pkgdesc = Python2 (tk) Ham Radio DX-Cluster GUI
pkgver = 2.21
- pkgrel = 1
+ pkgrel = 2
url = http://sourceforge.net/projects/pydxcluster/
arch = any
license = GPL3
depends = python2-requests
depends = python2-pygame
+ depends = python2-xmltodict
+ depends = hamradio-menus
source = https://downloads.sourceforge.net/project/pydxcluster/pyDXCluster%20v2.21/pyDXCluster_v2_21.tar.gz
source = pydxcluster.desktop
source = pydxcluster.png
@@ -14,11 +16,11 @@ pkgbase = pydxcluster
md5sums = d49f29f55cadf08c60c65b0d92dd8e8a
md5sums = 047de11f8b1f7a2433008d10732341da
md5sums = d03076d6792be993b1d52cece985373d
- md5sums = 64f0cac2f172f022edeb2e27e8c36841
+ md5sums = 91e8c4dec7b2db265d08daa8d6701c45
sha256sums = f6dc61f23edda77d1346082ba7b14ab3f627a6cd746fd7db04de361975bf1e2c
sha256sums = b79a160b020a66a2f02d6bda7c5e1772c01c74fce4caa6a3eb5e8eeeb506a83e
sha256sums = 797cd5764b045edf71c95f2b874d2705e8296460730e80e2b32311b6705c33a8
- sha256sums = 470797e4d8a4dddce8c07cd4baf7559cd6635b28e80abd013b0acefbfda1a476
+ sha256sums = e0a3e54cefe7cbe72392bf0168414377187d7deab000a25c563bf0d761817f24
pkgname = pydxcluster
diff --git a/PKGBUILD b/PKGBUILD
index a4e6128c9dc5..5ab8b07b6c18 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=pydxcluster
pkgver=2.21
-pkgrel=1
+pkgrel=2
pkgdesc="Python2 (tk) Ham Radio DX-Cluster GUI"
_dist=pyDxCluster
__dist=pyDXCluster
@@ -10,7 +10,8 @@ _ver=v2_21
arch=('any')
url="http://sourceforge.net/projects/pydxcluster/"
license=('GPL3')
-depends=('python2-requests' 'python2-pygame')
+depends=('python2-requests' 'python2-pygame' 'python2-xmltodict' 'hamradio-menus')
+# "python2-xmltodict" is listed as a dep by the author. Is it really required ?? (!!)
source=(https://downloads.sourceforge.net/project/$pkgname/$__dist%20v$pkgver/${__dist}_$_ver.tar.gz
$pkgname.desktop
$pkgname.png
@@ -22,6 +23,8 @@ prepare() {
mv ${_dist}_${_ver}.py $pkgname.py
rm -f *.txt
sed -i 's:LICENSE:/usr/share/licenses/common/GPL3/license:' $pkgname.py
+ sed -i 's:bin/python:bin/python2:' $pkgname.py
+ # ^^^ this is required to make 'namcap' happy...wrapper takes care of this anyways.
}
package() {
@@ -43,8 +46,8 @@ package() {
md5sums=('d49f29f55cadf08c60c65b0d92dd8e8a'
'047de11f8b1f7a2433008d10732341da'
'd03076d6792be993b1d52cece985373d'
- '64f0cac2f172f022edeb2e27e8c36841')
+ '91e8c4dec7b2db265d08daa8d6701c45')
sha256sums=('f6dc61f23edda77d1346082ba7b14ab3f627a6cd746fd7db04de361975bf1e2c'
'b79a160b020a66a2f02d6bda7c5e1772c01c74fce4caa6a3eb5e8eeeb506a83e'
'797cd5764b045edf71c95f2b874d2705e8296460730e80e2b32311b6705c33a8'
- '470797e4d8a4dddce8c07cd4baf7559cd6635b28e80abd013b0acefbfda1a476')
+ 'e0a3e54cefe7cbe72392bf0168414377187d7deab000a25c563bf0d761817f24')
diff --git a/pydxcluster.1 b/pydxcluster.1
index 22cd4ef4d90e..d26e8a0cfce6 100644
--- a/pydxcluster.1
+++ b/pydxcluster.1
@@ -1,6 +1,8 @@
#!/bin/sh
-mkdir -p $HOME/pydxcluster
+mkdir -p $HOME/pydxcluster/backup
cd $HOME/pydxcluster
-cp -a pydxcluster.cfg pydxcluster.cfg.backup
+cp -a *.cfg *.col backup/.
+cp -an backup/pydxcluster.cfg backup/pydxcluster.cfg.backup
cp -ua /usr/share/pydxcluster/* .
+cp -a backup/* .
exec python2 pydxcluster.py