summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJim Heald2016-11-21 12:56:00 -0800
committerJim Heald2016-11-21 12:56:00 -0800
commitb1dbf9831207cb47a9ee9a0d1c4a34ef5010e872 (patch)
tree79d3c17e8e70fe7094dc70de7def8fa0298b4cd7
parent97972795ef97c32bd5dd45fc8153a2d663420e0f (diff)
downloadaur-b1dbf9831207cb47a9ee9a0d1c4a34ef5010e872.tar.gz
Added a desktop entry
-rw-r--r--PKGBUILD5
-rw-r--r--pyflowchart.desktop5
2 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f44ce490b109..f658e23320f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,8 +9,8 @@ url="https://github.com/steelcowboy/PyFlowChart"
license=('BSD')
depends=('python-setuptools' 'gobject-introspection' 'python-gobject')
makedepends=('git' 'python-pip' 'cython')
-source=("git+https://github.com/steelcowboy/PyFlowChart.git")
-sha256sums=('SKIP')
+source=("git+https://github.com/steelcowboy/PyFlowChart.git" "pyflowchart.desktop")
+sha256sums=('SKIP' '5f1cfdfd272605ac2db8a644ad07dd6a49eea91a90529b4b7994de45883c0b65')
build() {
cd PyFlowChart
@@ -22,6 +22,7 @@ package() {
python setup.py install -O1 --prefix=/usr --root="$pkgdir"
install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
+ install -Dm644 "$srcdir/pyflowchart.desktop" "$pkgdir/usr/share/applications/pyflowchart.desktop"
}
# vim:set ts=2 sw=2 et:
diff --git a/pyflowchart.desktop b/pyflowchart.desktop
new file mode 100644
index 000000000000..9d429081bed1
--- /dev/null
+++ b/pyflowchart.desktop
@@ -0,0 +1,5 @@
+[Desktop Entry]
+Name=PyFlowChart
+Comment=Create flowcharts for Cal Poly
+Exec=pyflowchart
+Type=Application