summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKarl Hepworth2022-01-08 11:11:01 +1100
committerKarl Hepworth2022-01-08 11:11:01 +1100
commit896c5543afac07470d61e2ba882945aeeabd2180 (patch)
tree7916384d0ad8b13ecf903fab4a1c9a5d96cb6ab5
downloadaur-pygmy-git.tar.gz
rework so that it works again :)
Signed-off-by: Karl Hepworth <karl.hepworth@gmail.com>
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore6
-rw-r--r--LICENSE19
-rw-r--r--PKGBUILD35
4 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eebebe233a2f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = pygmy-git
+ pkgdesc = Amazee.io's local docker development tool
+ pkgver = v0.7.1.r14.g93af147
+ pkgrel = 1
+ url = https://github.com/pygmystack/pygmy
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = go-pie
+ provides = pygmy
+ conflicts = pygmy
+ conflicts = pygmy-bin
+ conflicts = pygmy-go
+ conflicts = pygmy-go-bin
+ conflicts = pygmy-go-git
+ source = git://github.com/pygmystack/pygmy.git
+ sha512sums = SKIP
+
+pkgname = pygmy-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f811a0d1ca57
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+.idea/*
+pkg/*
+src/*
+pygmy-*
+pygmy_*
+pygmy/* \ No newline at end of file
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..916b2291a401
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,19 @@
+// Copyright © 2019 Karl Hepworth <Karl.Hepworth@gmail.com>
+//
+// Permission is hereby granted, free of charge, to any person obtaining a copy
+// of this software and associated documentation files (the "Software"), to
+// deal in the Software without restriction, including without limitation the
+// rights to use, copy, modify, merge, publish, distribute, sublicense, and/or
+// sell copies of the Software, and to permit persons to whom the Software is
+// furnished to do so, subject to the following conditions:
+//
+// The above copyright notice and this permission notice shall be included in
+// all copies or substantial portions of the Software.
+//
+// THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+// IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+// FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+// AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+// LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+// FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS
+// IN THE SOFTWARE. \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6791ba20fa6f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: fubarhouse
+pkgname=pygmy-git
+cleanname=pygmy
+provides=(pygmy)
+pkgver=v0.7.1.r14.g93af147
+pkgrel=1
+pkgdesc="Amazee.io's local docker development tool"
+arch=('x86_64')
+url="https://github.com/pygmystack/pygmy"
+license=('MIT')
+conflicts=(pygmy pygmy-bin pygmy-go pygmy-go-bin pygmy-go-git)
+makedepends=(git go-pie)
+source=(git://github.com/pygmystack/pygmy.git)
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$cleanname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build(){
+ cd "$cleanname"
+ go mod vendor
+ go build \
+ -mod=vendor \
+ -trimpath \
+ -ldflags "-extldflags ${LDFLAGS}" \
+ .
+}
+
+package() {
+ cd "$cleanname"
+ install -Dm755 "$cleanname" "$pkgdir/usr/bin/$cleanname"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$cleanname/LICENSE"
+}