summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Griffis2016-04-22 14:28:24 -0400
committerPatrick Griffis2016-04-22 14:28:24 -0400
commitdf66b4c9bd84c9650396af7d46933bad207d7872 (patch)
tree5a8261ba6c501d3295b56e012208334468647f91
downloadaur-pygobject-docs-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD31
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4e57205b303a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = pygobject-docs-git
+ pkgdesc = Devhelp documentation for PyGObject libraries
+ pkgver = r1.gaded0d4
+ pkgrel = 1
+ url = https://github.com/lazka/pgi-docs-devhelp
+ arch = any
+ license = LGPL2
+ depends = devhelp
+ options = !strip
+ source = git+https://github.com/lazka/pgi-docs-devhelp.git
+ md5sums = SKIP
+
+pkgname = pygobject-docs-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b957b3f48d67
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: TingPing tingping@tingping.se
+
+pkgname=pygobject-docs-git
+pkgver=r1.gaded0d4
+pkgrel=1
+pkgdesc='Devhelp documentation for PyGObject libraries'
+arch=('any')
+url='https://github.com/lazka/pgi-docs-devhelp'
+license=('LGPL2')
+options=('!strip')
+depends=('devhelp')
+source=('git+https://github.com/lazka/pgi-docs-devhelp.git')
+md5sums=('SKIP')
+_gitname='pgi-docs-devhelp'
+
+pkgver() {
+ cd "$_gitname"
+
+ _rev=`git rev-list --count HEAD`
+ _hash=`git describe --always`
+ echo "r$_rev.g$_hash"
+}
+
+package() {
+ cd "$_gitname"
+
+ _dest="$pkgdir/usr/share/devhelp/books"
+
+ mkdir -p "$_dest"
+ cp --no-preserve=all -r python-* "$_dest"
+}