summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2023-04-15 08:24:24 -0500
committerCarlos Aznarán Laos2023-04-15 08:24:24 -0500
commitad0d9c5c8457205116369b111107c1b69e4c56b6 (patch)
tree3805ff32f02680fec7808c9ce1a60c72971e1f7d
parent30810ddb35e5ad8d4721c03e5fbf475ae52ee69f (diff)
downloadaur-ad0d9c5c8457205116369b111107c1b69e4c56b6.tar.gz
Bump version to 23.1
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD10
3 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2a5fc6e8aae5..a5d82c155614 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = pypy3-pip
pkgdesc = The PyPA recommended tool for installing Python packages
- pkgver = 23.0.1
+ pkgver = 23.1
pkgrel = 1
url = https://pip.pypa.io
arch = any
license = MIT
depends = pypy3
depends = pypy3-setuptools
- source = https://github.com/pypa/pip/archive/23.0.1/pip-23.0.1.tar.gz
- sha512sums = ed14ce37293e749b4fd93d7f93d81356c77428b1fb14dfd760b59aea720ebb3cce5a49c2d32ab600e73b37389937830ff4dee04750e83078c8ab9d57513f294c
- b2sums = 1781b0340ba7f76299fa8e37f0509f15a08cc599d196c74b90a2cb79321de570240ed9f12bc64d45ede2182ec8a3eead44ce1b840eaa83931d089ecc07923203
+ source = https://github.com/pypa/pip/archive/23.1/pip-23.1.tar.gz
+ sha512sums = ba1417811d69462b1e858d6a431abdafdf66a217f9fb25ad9c8430b3ea5289c631a282f3c399f607539d2ce9e2a71b556926f6ebf30be18d86ccda192afe0dfb
+ b2sums = 2d4e0dcfa730fe68b6b73d87fb3706a5c68f8eb497fe84c15a8a4ed5aa436a5ef07949d3c3d1393aa836bc8d2f67dbfad25609f807519a3d36b3aed34aff4756
pkgname = pypy3-pip
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f59ec20aabf5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 33a0062964c9..30c9bf77fc3e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
# Contributor: Sebastien Binet <binet@lblbox>
_base=pip
pkgname=pypy3-${_base}
-pkgver=23.0.1
+pkgver=23.1
pkgrel=1
pkgdesc="The PyPA recommended tool for installing Python packages"
url="https://pip.pypa.io"
@@ -16,8 +16,8 @@ arch=(any)
license=(MIT)
depends=(pypy3 pypy3-setuptools)
source=(https://github.com/pypa/${_base}/archive/${pkgver}/${_base}-${pkgver}.tar.gz)
-sha512sums=('ed14ce37293e749b4fd93d7f93d81356c77428b1fb14dfd760b59aea720ebb3cce5a49c2d32ab600e73b37389937830ff4dee04750e83078c8ab9d57513f294c')
-b2sums=('1781b0340ba7f76299fa8e37f0509f15a08cc599d196c74b90a2cb79321de570240ed9f12bc64d45ede2182ec8a3eead44ce1b840eaa83931d089ecc07923203')
+sha512sums=('ba1417811d69462b1e858d6a431abdafdf66a217f9fb25ad9c8430b3ea5289c631a282f3c399f607539d2ce9e2a71b556926f6ebf30be18d86ccda192afe0dfb')
+b2sums=('2d4e0dcfa730fe68b6b73d87fb3706a5c68f8eb497fe84c15a8a4ed5aa436a5ef07949d3c3d1393aa836bc8d2f67dbfad25609f807519a3d36b3aed34aff4756')
build() {
cd ${_base}-${pkgver}
@@ -26,9 +26,9 @@ build() {
package() {
cd ${_base}-${pkgver}
- pypy3 setup.py install --prefix=/opt/pypy3/ --root="${pkgdir}"
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" pypy3 setup.py install --prefix=/opt/pypy3/ --root="${pkgdir}"
- mkdir -p "${pkgdir}/usr/bin/"
+ mkdir -p "${pkgdir}/usr/bin"
mv "${pkgdir}/opt/pypy3/bin/pip" "${pkgdir}/usr/bin/pip-pypy3"
install -Dm 644 LICENSE.txt -t "${pkgdir}/usr/share/licenses/${pkgname}"