summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichel Zou2022-05-03 19:56:35 +0200
committerMichel Zou2022-05-03 19:56:35 +0200
commit462e51b851e57ffed5620e82fe73761ec8a3b724 (patch)
tree373408fc1c89d3fdfc0fd76bd81e726cb354326d
downloadaur-pypy3-ply.tar.gz
3.11
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD17
2 files changed, 30 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..68038a052178
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = pypy3-ply
+ pkgdesc = Implementation of lex and yacc parsing tools
+ pkgver = 3.11
+ pkgrel = 1
+ url = https://www.dabeaz.com/ply/
+ arch = any
+ license = BSD
+ makedepends = pypy3-setuptools
+ depends = pypy3
+ source = https://pypi.io/packages/source/p/ply/ply-3.11.tar.gz
+ sha512sums = 37e39a4f930874933223be58a3da7f259e155b75135f1edd47069b3b40e5e96af883ebf1c8a1bbd32f914a9e92cfc12e29fec05cf61b518f46c1d37421b20008
+
+pkgname = pypy3-ply
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bccdcc0ad9fe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+pkgname=pypy3-ply
+pkgver=3.11
+pkgrel=1
+pkgdesc='Implementation of lex and yacc parsing tools'
+arch=('any')
+url='https://www.dabeaz.com/ply/'
+license=('BSD')
+depends=('pypy3')
+makedepends=('pypy3-setuptools')
+source=("https://pypi.io/packages/source/p/ply/ply-$pkgver.tar.gz")
+sha512sums=('37e39a4f930874933223be58a3da7f259e155b75135f1edd47069b3b40e5e96af883ebf1c8a1bbd32f914a9e92cfc12e29fec05cf61b518f46c1d37421b20008')
+
+package() {
+ cd "ply-$pkgver"
+ pypy3 setup.py install --prefix=/opt/pypy3 --root="$pkgdir"
+}
+