summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGianluca Montecchi2015-06-08 21:52:26 +0200
committerGianluca Montecchi2015-06-08 21:52:26 +0200
commitf91536bbca8aef550e4fad86b2ae69542bbb97da (patch)
tree09daa88d9a368116922228a7809ff720fc1b0cf3
downloadaur-pyqglviewer.tar.gz
Initial import
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD50
2 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f55586edbb8d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = pyqglviewer
+ pkgdesc = Python binding for libQGLViewer C++ library
+ pkgver = 0.11
+ pkgrel = 4
+ url = http://pyqglviewer.gforge.inria.fr/wiki/doku.php
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ license = GPL3
+ license = custom
+ makedepends = patch
+ makedepends = python2
+ depends = qt4
+ depends = python2
+ depends = python2-opengl
+ depends = glu
+ depends = mesa
+ depends = python2-pyqt
+ options = !makeflags
+ source = https://gforge.inria.fr/frs/download.php/30908//PyQGLViewer-0.11.zip
+ source = https://gforge.inria.fr/frs/download.php/30907/libQGLViewer-2.3.17-py.tgz
+ md5sums = cc7d847989fd6af9ac51736cec864e4b
+ md5sums = 75bc31ba4742d5fd9ddf5abba3bfa532
+
+pkgname = pyqglviewer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..601c7fcb2242
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Gianluca Montecchi <gian@grys.it>
+# Contributor: Geoffroy Carrier <geoffroy.carrier@aur.archlinux.org>
+# Contributor: Dmitriy Morozov <archlinux@foxcub.org>
+# Contributor: Larry Hajali <larryhaja [at] gmail [dot] com>
+
+pkgname=pyqglviewer
+_pkgname=libQGLViewer
+_pglname=PyQGLViewer
+_pkgver=2.3.17
+pkgver=0.11
+pkgrel=4
+pkgdesc="Python binding for libQGLViewer C++ library"
+url="http://pyqglviewer.gforge.inria.fr/wiki/doku.php"
+depends=('qt4' 'python2' 'python2-opengl' 'glu' 'mesa' 'python2-pyqt')
+makedepends=('patch' 'python2')
+arch=('i686' 'x86_64')
+license=('GPL2' 'GPL3' 'custom')
+options=(!makeflags)
+source=(
+ https://gforge.inria.fr/frs/download.php/30908//${_pglname}-${pkgver}.zip
+ https://gforge.inria.fr/frs/download.php/30907/${_pkgname}-${_pkgver}-py.tgz)
+
+md5sums=('cc7d847989fd6af9ac51736cec864e4b'
+ '75bc31ba4742d5fd9ddf5abba3bfa532')
+
+build()
+{
+# cd $srcdir/${_pkgname}-${_pkgver}-py
+ # dos2unix?
+# qmake-qt4 -o Makefile ${_pkgname}-${_pkgver}.pro || return 1
+
+# make install INSTALL_ROOT="$pkgdir"
+
+# # Install license.
+# cd $srcdir/${_pkgname}-${_pkgver}-py
+# install -d -m 0755 "${pkgdir}"/usr/share/licenses/$_pkgname/ || return 1
+# install -m 0644 licence.txt GPL_exception.txt "${pkgdir}"/usr/share/licenses/$_pkgname/ || return 1
+
+ # PyQGLViewer
+ cd $srcdir/$_pglname
+ python2 configure.py -Q ../${_pkgname}-${_pkgver}-py --extra-libs GLU
+}
+
+
+package()
+{
+ make
+ make install DESTDIR=$pkgdir
+
+}