summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122018-12-05 11:05:00 +0100
committerwillemw122018-12-05 11:05:00 +0100
commit5c6f9a743a460a12d1de56e95f1a868c030f1063 (patch)
tree2e9cc4cdede957453434103a4b481236d012c293
parent0bc64d42529a4a6e1926cafc18dfd85ff001b66b (diff)
downloadaur-5c6f9a743a460a12d1de56e95f1a868c030f1063.tar.gz
Update PKGBUILD (provided by sng) and remove man page file
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD24
-rw-r--r--pyradio.181
3 files changed, 15 insertions, 94 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2ca13f71464e..5e6fc6d19bb9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pyradio-git
pkgdesc = Command line internet radio player
- pkgver = 0.4.r142.g882da1e
+ pkgver = 0.6.0.r0.gd13b7e3
pkgrel = 1
url = http://www.coderholic.com/pyradio/
arch = any
@@ -16,9 +16,7 @@ pkgbase = pyradio-git
provides = pyradio
conflicts = pyradio
source = pyradio-git::git://github.com/coderholic/pyradio.git
- source = pyradio.1
md5sums = SKIP
- md5sums = 53460ef86b415aca61eba663ecc4240e
pkgname = pyradio-git
diff --git a/PKGBUILD b/PKGBUILD
index a63df23679af..e1d7bceec108 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: willemw <willemw12@gmail.com>
-# Contributor: sng
+# Contributor: sng <sng at hellug dot gr>
# Contributor: aksr <aksr at t-com dot me>
_pkgname=pyradio
pkgname=$_pkgname-git
-pkgver=0.4.r142.g882da1e
+pkgver=0.6.0.r0.gd13b7e3
pkgrel=1
pkgdesc="Command line internet radio player"
arch=('any')
@@ -15,10 +15,8 @@ optdepends=('mplayer: as backend' 'vlc: as backend' 'mpv: as backend' 'socat: if
makedepends=('git' 'python-setuptools')
provides=($_pkgname)
conflicts=($_pkgname)
-source=($pkgname::git://github.com/coderholic/pyradio.git
- pyradio.1)
-md5sums=('SKIP'
- '53460ef86b415aca61eba663ecc4240e')
+source=($pkgname::git://github.com/coderholic/pyradio.git)
+md5sums=('SKIP')
pkgver() {
cd $pkgname
@@ -26,12 +24,18 @@ pkgver() {
}
package() {
- install -Dm644 pyradio.1 "$pkgdir/usr/share/man/man1/pyradio.1"
-
cd $pkgname
+ descr="$(git describe --long --tags)"
+ sed -i "s/git_description = ''/git_description = '$descr'/" pyradio/radio.py
python setup.py install --root="$pkgdir" --optimize=1
install -Dm644 LICENCE "$pkgdir/usr/share/licenses/pyradio/LICENSE"
install -Dm644 README.md "$pkgdir/usr/share/doc/pyradio/README.md"
- install -Dm644 pyradio/stations.csv "$pkgdir/usr/share/doc/pyradio/stations.csv"
-}
+ install -Dm644 README.html "$pkgdir/usr/share/doc/pyradio/README.html"
+ install -Dm644 build.md "$pkgdir/usr/share/doc/pyradio/build.md"
+ install -Dm644 build.html "$pkgdir/usr/share/doc/pyradio/build.html"
+ gzip pyradio.1
+ install -Dm644 pyradio.1.gz "$pkgdir/usr/share/man/man1/pyradio.1.gz"
+ # We don't have to install stations.csv, it is already in the egg file
+ #install -Dm644 pyradio/stations.csv "$pkgdir/usr/share/doc/pyradio/stations.csv"
+}
diff --git a/pyradio.1 b/pyradio.1
deleted file mode 100644
index 94d3f8b428dc..000000000000
--- a/pyradio.1
+++ /dev/null
@@ -1,81 +0,0 @@
-.\" Copyright (C) 2011 Ben Dowling <http://www.coderholic.com/pyradio>
-.\" This manual is freely distributable under the terms of the GPL.
-.\"
-.TH PYRADIO 1 "November 2018"
-
-.SH NAME
-.PP
-pyradio \- a console based Internet radio player
-
-.SH SYNOPSIS
-.PP
-\fBpyradio\fR
-.RI \fI[OPTIONS]
-[path/to/]stations.csv
-
-.SH DESCRIPTION
-.PP
-.B pyradio
-is a command line internet radio player.
-.PP
-It will use one of the following players: \fImpv\fR, \fImplayer\fR or \fIvlc\fR, detected in that order. If none of them is detected, \fBpyradio\fR will \fBsilently\ terminate\fR (use \fB-d\fR option to get a log file).
-.PP
-If \fImpv\fR is detected, \fIsocat\fR is required too.
-.PP
-It is possible to use
-a custom stations list in \fB~/.pyradio/stations.csv.
-.PP
-If custom stations list is missing, \fBpyradio\fR would use a
-default one.
-
-.SH OPTIONS
-
-.IP \fB-h\fR,\fB\ \--help
-Show this help message and exit.
-.IP \fB-s\fR,\fB\ \--stations\ \fI[STATIONS]
-Use specified station CSV file.
-.IP \fB-p\fR,\fB\ \--play\ \fI\<PLAY\>
-Play station number \fI\<PLAY\>\fR. Select randome station if \fI\<PLAY\>\fR not specified.
-.IP \fB-r\fR,\fB\ \--random
-Start and play a random station.
-.IP \fB-a\fR,\fB\ \--add
-Add station to list.
-.IP \fB-l\fR,\fB\ \--list
-List of added stations.
-.IP \fB-u\fR,\fB\ \--use-player\ \fI[USE_PLAYER]
-Specify which player to use (\fImpv\fR,\ \fImplayer\fR\ or\ \fIcvlc\fR).
-.IP \fB-d\fR,\fB\ \--debug
-Debug mode (pyradio.log created). To be attached with any bug report.
-
-.SH CONTROLS
-
-.IP \fB\Up/Down/PgUp/PgDown
-Change station selection
-.IP \fBj/k
-Change station selection (vi-like)
-.IP \fBEnter
-Play selected station
-.IP \fB-/+
-Change volume
-.IP \fBv
-Save volume (mpv and mplayer only)
-.IP \fBm
-Mute
-.IP \fBr
-Select and play a random station
-.IP \fBSpace
-Stop/start playing selected station
-.IP \fBEsc/q
-Quit
-
-.SH FILES
-.PP
-.I /usr/share/doc/pyradio/stations.csv
-
-.I /usr/share/doc/pyradio/README.md
-
-.I /usr/share/licenses/pyradio/LICENSE
-
-.SH AUTHOR
-.PP
- \fBBen Dowling <http://www.coderholic.com/pyradio>