summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSpiros Georgaras2021-08-24 13:01:19 +0300
committerSpiros Georgaras2021-08-24 13:01:19 +0300
commit97cd82010b94fcd8c5597b6284ea657ec024c318 (patch)
treea1ee2f26027f4d57bf0cd63b526ea0edbf730ff0
parentfd180fd62c71a143132043e0865010329dba17ec (diff)
downloadaur-97cd82010b94fcd8c5597b6284ea657ec024c318.tar.gz
adding pyradio_rb man page
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD9
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0239c6fbf520..03e818227913 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pyradio-git
pkgdesc = Internet radio player for the command line
pkgver = 0.8.9.8.r0.gd878cd3
- pkgrel = 1
+ pkgrel = 2
url = http://www.coderholic.com/pyradio/
arch = any
license = MIT
@@ -13,6 +13,7 @@ pkgbase = pyradio-git
optdepends = mpv: as backend
optdepends = vlc: as backend
provides = pyradio
+ conflicts = pyradio-git
conflicts = pyradio
source = pyradio-git::git+https://github.com/coderholic/pyradio.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 62ab299cb7fd..e6a8108b340b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=pyradio-git
pkgver=0.8.9.8.r0.gd878cd3
-pkgrel=1
+pkgrel=2
pkgdesc="Internet radio player for the command line"
arch=('any')
url="http://www.coderholic.com/pyradio/"
@@ -13,7 +13,7 @@ depends=('python-dnspython' 'python-requests')
optdepends=('mplayer: as backend' 'mpv: as backend' 'vlc: as backend')
makedepends=('git' 'python-setuptools')
provides=("${pkgname%-git}")
-conflicts=("${pkgname%-git}")
+conflicts=("${pkgname%}" "${pkgname%-git}")
source=($pkgname::git+https://github.com/coderholic/pyradio.git)
sha256sums=('SKIP')
@@ -21,7 +21,7 @@ prepare() {
cd $pkgname
_descr="$(git describe --long --tags)"
sed -i "s/git_description = ''/git_description = '$_descr'/" pyradio/radio.py
- sed -i 's/distro = None/distro = Arch Linux/' pyradio/config
+ sed -i 's/distro = None/distro = Arch Linux (AUR)/' pyradio/config
}
pkgver() {
@@ -32,10 +32,9 @@ pkgver() {
package() {
cd $pkgname
- #install -Dm644 LICENCE -t "$pkgdir/usr/share/licenses/pyradio"
install -Dm644 LICENCE "$pkgdir/usr/share/licenses/pyradio/LICENSE"
install -Dm644 README.{html,md} build.{html,md} -t "$pkgdir/usr/share/doc/pyradio"
- install -Dm644 pyradio.1 -t "$pkgdir/usr/share/man/man1"
+ install -Dm644 pyradio{,_rb}.1 -t "$pkgdir/usr/share/man/man1"
python setup.py install --root="$pkgdir" --optimize=1
}