summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAxel Gembe2019-12-02 12:12:29 +0700
committerAxel Gembe2019-12-02 12:12:29 +0700
commitf151ab99045e367553a78affeaa2adb8995af0fc (patch)
treea52594860d037ffdee0c76c2ba91690a74de95fe
parentbcab0a849f80cfe0739f5051404177bc10d447cb (diff)
downloadaur-f151ab99045e367553a78affeaa2adb8995af0fc.tar.gz
Switch to Python 3
PyRescene supports Python 3 so there is no reason to depend on Python 2. Thanks to hashworks for the suggestion!
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3c03888c6584..d2a0bd18778d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pyrescene-hg
pkgdesc = pyReScene is a port of ReScene .NET to the Python programming language.
pkgver = 806
- pkgrel = 3
+ pkgrel = 4
url = https://bitbucket.org/Gfy/pyrescene
arch = any
license = MIT
@@ -9,9 +9,9 @@ pkgbase = pyrescene-hg
license = Custom
makedepends = mercurial
makedepends = git
- depends = python2
+ depends = python
depends = chromaprint
- depends = python2-numpy
+ depends = python-numpy
depends = unrar
depends = lib32-libstdc++5
source = hg+https://bitbucket.org/Gfy/pyrescene/
diff --git a/PKGBUILD b/PKGBUILD
index 5671eb47fe0a..a62523695665 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
-# Maintainer: dryes <joswiseman@cock.li>
+# Maintainer: ichundes <derago@gmail.com>
pkgname='pyrescene-hg'
pkgver=806
-pkgrel=3
+pkgrel=4
pkgdesc='pyReScene is a port of ReScene .NET to the Python programming language.'
url='https://bitbucket.org/Gfy/pyrescene'
arch=('any')
license=('MIT' 'GPL' 'Custom')
-depends=('python2' 'chromaprint' 'python2-numpy' 'unrar' 'lib32-libstdc++5')
+depends=('python' 'chromaprint' 'python-numpy' 'unrar' 'lib32-libstdc++5')
makedepends=('mercurial' 'git')
source=('hg+https://bitbucket.org/Gfy/pyrescene/' 'git://github.com/dryes/rarlinux.git')
md5sums=('SKIP'
@@ -22,11 +22,11 @@ package() {
cp 'rescene/srr.py' 'rescene/srr.py~'
sed -i -r 's|(dest=\"rar_executable_dir\",)|\1 default=\"/opt/rarlinux\",|' 'rescene/srr.py'
- python2 'setup.py' install --root="${pkgdir}"
+ python 'setup.py' install --root="${pkgdir}"
mv 'rescene/srr.py~' 'rescene/srr.py'
mkdir -p "${pkgdir}/opt/rarlinux"
- python2 'bin/preprardir.py' "${srcdir}/rarlinux" "${pkgdir}/opt/rarlinux"
+ python 'bin/preprardir.py' "${srcdir}/rarlinux" "${pkgdir}/opt/rarlinux"
chown -R root:root "${pkgdir}/opt/rarlinux"
chmod -R a+x "${pkgdir}/opt/rarlinux"
# RAR 5.50 breaks pyrescene