summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Wolf2015-08-26 12:42:28 +0200
committerSebastian Wolf2015-08-26 12:42:28 +0200
commit6582b7151d01bd3961f7c84c7bb50608d66f20f6 (patch)
tree67951db21a03d36306ac23d6a03f8cf9c0386f8b
downloadaur-pysize.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ea7faaaa37e1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = pysize
+ pkgdesc = A graphical and console tool for exploring the size of directories
+ pkgver = 0.2
+ pkgrel = 1
+ url = http://guichaz.free.fr/pysize/
+ arch = any
+ license = GPL
+ depends = python2
+ optdepends = pygtk: GTK+ GUI
+ source = http://guichaz.free.fr/pysize/files/pysize-0.2.tar.bz2
+ md5sums = e25fea5169b12e49f732f29a3de30d80
+
+pkgname = pysize
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..82f0812b9ae1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Sebastian Wolf <swolf at melonkru dot de>
+pkgname=pysize
+pkgver=0.2
+pkgrel=1
+pkgdesc="A graphical and console tool for exploring the size of directories"
+arch=('any')
+license=('GPL')
+depends=('python2')
+optdepends=('pygtk: GTK+ GUI')
+url="http://guichaz.free.fr/pysize/"
+source=("http://guichaz.free.fr/${pkgname}/files/${pkgname}-${pkgver}.tar.bz2")
+md5sums=('e25fea5169b12e49f732f29a3de30d80')
+
+package() {
+ mkdir -p ${pkgdir}/usr/lib/ || return 1
+ mkdir -p ${pkgdir}/usr/bin/ || return 1
+
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ sed -i -e "s|#![ ]*/usr/bin/env python$|#!/usr/bin/python2|" ${pkgname}.py
+
+ cp -R pysize ${pkgdir}/usr/lib/ || return 1
+ install -Dm755 ${pkgname}.py "${pkgdir}/usr/lib/${pkgname}.py"
+
+ ln -s "/usr/lib/${pkgname}.py" "${pkgdir}/usr/bin/${pkgname}"
+}