summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoelof Rietbroek2018-04-16 22:14:41 +0200
committerRoelof Rietbroek2018-04-16 22:14:41 +0200
commit7ce6af3c1129e2c237cbcafe455bdaf5df7ab7d2 (patch)
tree1dd4793b349faea5a70e216585771eacb582e6a8
parent03212c0da03eb2ae9685c45b045720d3eda75e69 (diff)
downloadaur-pysofa.tar.gz
make pysofa work woth python 3
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
-rw-r--r--init.patch9
3 files changed, 18 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 00c45aead134..737c49f2c6a1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,12 +5,14 @@ pkgbase = pysofa
url = https://code.google.com/archive/p/pysofa/
arch = any
license = SOFA License
- depends = sofa
+ depends = sofa-shared
depends = python-numpy
source = https://pypi.python.org/packages/f5/fd/557bc955527164df6d5699ba2369415a26767a90e848ce362600435d4553/pysofa-0.1.1.tar.gz
source = octonotationpatch.diff
+ source = init.patch
md5sums = 962be6439044b4ff666f735b2207aaa8
md5sums = 5e6cef758d9861cba2e72eb2faff3ee4
+ md5sums = 60a155956101026a32c79eb22f03602f
pkgname = pysofa
diff --git a/PKGBUILD b/PKGBUILD
index 504f3f6e465c..f4c64c35c069 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Arch User repository PKGBUILD file
# Builds the python interface for the SOFA library
-# Maintainer: Roelof Rietbroek <roelof@wobbly.earth>
+# Contributor: Roelof Rietbroek <roelof@wobbly.earth>
pkgname=pysofa
pkgver=0.1.1
pkgrel=1
@@ -9,12 +9,13 @@ arch=('any')
url="https://code.google.com/archive/p/pysofa/"
license=('SOFA License')
groups=()
-depends=("sofa" "python-numpy")
+depends=("sofa-shared" "python-numpy")
makedepends=()
-source=("https://pypi.python.org/packages/f5/fd/557bc955527164df6d5699ba2369415a26767a90e848ce362600435d4553/pysofa-$pkgver.tar.gz" "octonotationpatch.diff")
+source=("https://pypi.python.org/packages/f5/fd/557bc955527164df6d5699ba2369415a26767a90e848ce362600435d4553/pysofa-$pkgver.tar.gz" "octonotationpatch.diff" "init.patch")
noextract=()
md5sums=('962be6439044b4ff666f735b2207aaa8'
- '5e6cef758d9861cba2e72eb2faff3ee4')
+ '5e6cef758d9861cba2e72eb2faff3ee4'
+ '60a155956101026a32c79eb22f03602f')
validpgpkeys=()
prepare() {
@@ -22,6 +23,7 @@ prepare() {
cd ${srcdir}
#patch some files to get rid of the octo notation (doesn't work in python 3)
patch pysofa-${pkgver}/pysofa/pysofa_ctypes.py octonotationpatch.diff
+ patch pysofa-${pkgver}/pysofa/__init__.py init.patch
cd ${_startdir}
}
diff --git a/init.patch b/init.patch
new file mode 100644
index 000000000000..2c77a5ca7b04
--- /dev/null
+++ b/init.patch
@@ -0,0 +1,9 @@
+--- tmp/pysofa-0.1.1/pysofa/__init__.py 2010-11-29 11:02:06.000000000 +0100
++++ initnew.py 2018-04-16 21:55:06.818227322 +0200
+@@ -6,5 +6,5 @@
+ # Distributed under the terms of the MIT license.
+ #
+
+-from pysofa_ctypes import *
++from pysofa.pysofa_ctypes import *
+