summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobert Kubosz2018-01-29 23:26:55 +0100
committerRobert Kubosz2018-01-29 23:28:44 +0100
commit3789278b6bc01e4c5adf50f5c3cf3c6ed33461f6 (patch)
tree0a385031774e21980339ab5cb69f9786f34f9591
parentf8a73cad6450fc037869f21308f5a73f255f0b91 (diff)
downloadaur-3789278b6bc01e4c5adf50f5c3cf3c6ed33461f6.tar.gz
remove python2 package
The package for python2 will be placed in separate PKGBUILD since there are conflicts between python-abjad and python2-abjad.
-rw-r--r--PKGBUILD65
1 files changed, 27 insertions, 38 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f6b93548146f..0d72c713c2ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,51 +1,40 @@
# Maintainer: Robert Kubosz <kubosz.robert@gmail.com>
-pkgbase=python-abjad
-pkgname=(python-abjad python2-abjad)
+pkgname=python-abjad
pkgver=2.21
pkgrel=1
-pkgdesc="Tool for formalized music score control. Package for Python"
-arch=('any')
+pkgdesc="Tool for formalized music score control."
+arch=("any")
url="https://github.com/Abjad/abjad"
-license=('GPL 3')
-depends=('lilypond')
-optdepends=('graphviz: to create rhythm-trees graphs and other tree structures'
- 'timidity++: to play generated MIDI files'
- 'jupyter: browser-based interactive notebook for programming')
+license=("GPL 3")
+depends=(
+ "lilypond"
+ "python"
+ "python-ply"
+ "python-six"
+ )
+makedepends=("python-setuptools")
+conflicts=('python2-abjad')
+optdepends=(
+ "graphviz: to create rhythm-trees graphs and other tree structures"
+ "fluidsynth: to play generated MIDI files (instead of timidity++)"
+ "timidity++: to play generated MIDI files (instead of fluidsynth)"
+ "jupyter: browser-based interactive notebook for programming"
+ "ipython: an enhanced Python console"
+ "python-ipywidgets: IPython widgets for Jupyter notebook"
+ "python-pypdf2: PDF toolkit"
+ )
source=("$url/archive/v$pkgver.tar.gz")
-sha256sums=('5fc1fc977b9521d4b9ce1aa8bdea1aa07306e313bd03feea15e8c680b4f27c5b')
-
-prepare() {
- cp -rup $srcdir/abjad-$pkgver $srcdir/abjad-$pkgver-python2
-}
-
-package_python-abjad() {
- depends+=('python' 'python-ply' 'python-six')
- makedepends=('python-setuptools')
- optdepends+=( 'ipython: an enhanced Python console'
- 'python-ipywidgets: IPython widgets for Jupyter notebook'
- 'python-pypdf2: PDF toolkit')
- pkgdesc+=" 3"
+sha256sums=("5fc1fc977b9521d4b9ce1aa8bdea1aa07306e313bd03feea15e8c680b4f27c5b")
+build() {
cd $srcdir/abjad-$pkgver
-
- #optimize option causes build errors, so it is commented
- python setup.py install --root="$pkgdir/" #--optimize=1
- install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ python setup.py build
}
-package_python2-abjad() {
- depends+=('python2' 'python2-ply' 'python2-six')
- makedepends=('python2-setuptools')
- optdepends+=( 'ipython2: an enhanced Python 2 console'
- 'python2-ipykernel: Python 2 support for Jupyter'
- 'python2-ipywidgets: IPython2 widgets for Jupyter notebook'
- 'python2-pypdf2: PDF toolkit')
- pkgdesc+=" 2"
-
- cd $srcdir/abjad-$pkgver-python2
-
- python2 setup.py install --root="$pkgdir/" #--optimize=1
+package() {
+ cd $srcdir/abjad-$pkgver
+ python setup.py install --root="$pkgdir/" --optimize=1
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}