summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-03-21 14:13:46 -0500
committerLuis Martinez2022-03-21 14:13:46 -0500
commit6528c9f2cac38d757604d689b5611d8aafc8cf4f (patch)
tree136cca8205a369c15abb9309e056c11ab6f469f8
parent20650166fb255fb5527acb89f861cc54999df071 (diff)
downloadaur-6528c9f2cac38d757604d689b5611d8aafc8cf4f.tar.gz
update to 1.4.84
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD14
-rw-r--r--changelog.md120
3 files changed, 133 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c20add0d1375..70029712218a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-akshare
pkgdesc = Financial data interface library
- pkgver = 1.4.65
+ pkgver = 1.4.84
pkgrel = 1
url = https://github.com/akfamily/akshare
changelog = changelog.md
@@ -16,12 +16,11 @@ pkgbase = python-akshare
makedepends = python-recommonmark
depends = python-beautifulsoup4
depends = python-lxml
- depends = python-matplotlib
depends = python-numpy
depends = python-pandas
depends = python-requests
+ depends = python-requests-cache
depends = python-urllib3
- depends = python-pillow
depends = python-pinyin
depends = python-websocket-client
depends = python-html5lib
@@ -32,7 +31,7 @@ pkgbase = python-akshare
depends = python-tabulate
depends = python-decorator
depends = python-pyminiracer
- source = python-akshare-1.4.65.tar.gz::https://github.com/akfamily/akshare/archive/release-v1.4.65.tar.gz
- sha256sums = 94709b4493b65ff15bc20b18b40110f5b4adc3a82f889d38cde6e8c77ec638be
+ source = python-akshare-1.4.84.tar.gz::https://github.com/akfamily/akshare/archive/release-v1.4.84.tar.gz
+ sha256sums = ee5cd4c85e296c9abe42e34706650c5d86fdd912bd746083e5db4706bfae60b9
pkgname = python-akshare
diff --git a/PKGBUILD b/PKGBUILD
index b8b20b65da44..1eb887506b99 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Dimitris Kiziridis <ragouel at outlook dot com>
pkgname=python-akshare
-pkgver=1.4.65
+pkgver=1.4.84
pkgrel=1
pkgdesc="Financial data interface library"
arch=('any')
@@ -11,12 +11,11 @@ license=('MIT')
depends=(
'python-beautifulsoup4'
'python-lxml'
- 'python-matplotlib'
'python-numpy'
'python-pandas'
'python-requests'
+ 'python-requests-cache'
'python-urllib3'
- 'python-pillow'
'python-pinyin'
'python-websocket-client'
'python-html5lib'
@@ -38,7 +37,7 @@ makedepends=(
'python-recommonmark')
changelog=changelog.md
source=("$pkgname-$pkgver.tar.gz::$url/archive/release-v$pkgver.tar.gz")
-sha256sums=('94709b4493b65ff15bc20b18b40110f5b4adc3a82f889d38cde6e8c77ec638be')
+sha256sums=('ee5cd4c85e296c9abe42e34706650c5d86fdd912bd746083e5db4706bfae60b9')
prepare() {
cd "akshare-release-v$pkgver"
@@ -55,6 +54,11 @@ package() {
export PYTHONHASHSEED=0
cd "akshare-release-v$pkgver"
python -m installer --destdir="$pkgdir/" dist/*.whl
- install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
install -Dm644 docs/build/man/akshare.1 -t "$pkgdir/usr/share/man/man1/"
+
+ local _site="$(python -c 'import site; print(site.getsitepackages()[0])')"
+ install -d "$pkgdir/usr/share/licenses/$pkgname/"
+ ln -s \
+ "$_site/akshare-$pkgver.dist-info/LICENSE" \
+ "$pkgdir/usr/share/licenses/$pkgname/"
}
diff --git a/changelog.md b/changelog.md
index 44fdce74289b..1c9862baedb5 100644
--- a/changelog.md
+++ b/changelog.md
@@ -2,6 +2,88 @@
## 接口更新说明
+1.4.84 fix: fix fund_portfolio_change_em interface
+
+ 1. 修复 fund_portfolio_change_em 接口,新增 indicator 字段
+
+1.4.83 add: add stock_us_code_table_fu interface
+
+ 1. 新增 stock_us_code_table_fu 接口,获取股票代码
+
+1.4.82 fix: fix stock_a_code_to_symbol interface
+
+ 1. 修复 stock_a_code_to_symbol 接口,支持北交所股票
+
+1.4.81 add: add fund_portfolio_change_em interface
+
+ 1. 新增 fund_portfolio_change_em 接口,获取天天基金网-基金档案-投资组合-重大变动数据
+
+1.4.80 add: add stock_board_concept_hist_min_em interface
+
+ 1. 新增 stock_board_concept_hist_min_em 接口,获取东方财富-沪深板块-概念板块-分时历史行情数据
+
+1.4.79 add: add stock_board_industry_hist_min_em interface
+
+ 1. 新增 stock_board_industry_hist_min_em 接口,获取东方财富-沪深板块-行业板块-分时历史行情数据
+
+1.4.78 add: add remove matplotlib module and support cache
+
+ 1. 移除 matplotlib 模块,让 AKShare 更专注于数据采集
+ 2. 新增缓存,对于速度较慢的接口逐步增加缓存支持
+ 3. 移除所有接口中的绘图功能
+ 4. 修复 google_index 接口
+ 5. 移除 西本新干线 接口
+ 6. 在 utils 模块中新增 ak_session 以支持缓存
+ 7. 添加 requests-cache 作为依赖库
+
+1.4.77 fix: fix stock_hk_ggt_components_em interface
+
+ 1. 修复 stock_hsgt_em 文件中的所有 pandas.DataFrame 的 append 方法为 concat
+
+1.4.76 add: add stock_lhb_stock_statistic_em interface
+
+ 1. 新增 stock_lhb_stock_statistic_em 接口,获取个股上榜统计数据
+
+1.4.75 fix: fix stock_lhb_stock_detail_em interface
+
+ 1. 修复 stock_lhb_stock_detail_em 接口,处理有多种排行标准的数据
+
+1.4.74 fix: fix stock_lhb_stock_detail_em interface
+
+ 1. 修复 stock_lhb_stock_detail_em 接口返回数据与目标网站统一
+
+1.4.73 add: add stock_lhb_jgmmtj_em interface
+
+ 1. 新增 stock_lhb_jgmmtj_em 接口,该接口获取机构买卖每日统计数据
+
+1.4.72 add: add stock_lhb_stock_statistic_em interface
+
+ 1. 新增 stock_lhb_stock_statistic_em 接口,该接口获取股票龙虎榜统计详情
+
+1.4.71 add: add stock_lhb_stock_detail_em interface
+
+ 1. 新增 stock_lhb_stock_detail_em 接口,该接口获取龙虎榜个股详情数据
+
+1.4.70 add: add stock_lhb_detail_em interface
+
+ 1. 新增 stock_lhb_detail_em 接口获取东方财富-股票数据-龙虎榜详情
+
+1.4.69 fix: fix crypto_js_spot interface
+
+ 1. 修复 crypto_js_spot 接口,规范字段名称及返回数据的格式
+
+1.4.68 fix: fix crypto_hist interface
+
+ 1. 修复 crypto_hist 接口,修改其中返回数据类型
+
+1.4.67 fix: fix crypto_name_url_table interface
+
+ 1. 修复 crypto_name_url_table 获取可以获得历史数据的货币名称
+
+1.4.66 fix: fix stock_em_gpzy_profile interface
+
+ 1. 修复 stock_em_gpzy_profile 接口并设定返回数据的数据类型
+
1.4.65 fix: fix spot_hist_sge interface
1. 修复 spot_hist_sge 接口的数据输出格式
@@ -100,6 +182,44 @@
## 版本更新说明
+1.4.84 fix: fix fund_portfolio_change_em interface
+
+1.4.83 add: add stock_us_code_table_fu interface
+
+1.4.82 fix: fix stock_a_code_to_symbol interface
+
+1.4.81 add: add fund_portfolio_change_em interface
+
+1.4.80 add: add stock_board_concept_hist_min_em interface
+
+1.4.79 add: add stock_board_industry_hist_min_em interface
+
+1.4.78 add: add remove matplotlib module and support cache
+
+1.4.77 fix: fix stock_hk_ggt_components_em interface
+
+1.4.76 add: add stock_lhb_stock_statistic_em interface
+
+1.4.75 fix: fix stock_lhb_stock_detail_em interface
+
+1.4.74 fix: fix stock_lhb_stock_detail_em interface
+
+1.4.73 add: add stock_lhb_jgmmtj_em interface
+
+1.4.72 add: add stock_lhb_stock_statistic_em interface
+
+1.4.71 add: add stock_lhb_stock_detail_em interface
+
+1.4.70 add: add stock_lhb_detail_em interface
+
+1.4.69 fix: fix crypto_js_spot interface
+
+1.4.68 fix: fix crypto_hist interface
+
+1.4.67 fix: fix crypto_name_url_table interface
+
+1.4.66 fix: fix stock_em_gpzy_profile interface
+
1.4.65 fix: fix spot_hist_sge interface
1.4.64 fix: fix bond_china_close_return interface