summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-04-06 10:25:31 -0500
committerLuis Martinez2022-04-06 10:25:31 -0500
commit7209f4f06a7fdcf7599258f99c4087f8117d1da8 (patch)
treee5b7a7fe2d1e5c439616811c004ed9cc38e2aeb9
parent6528c9f2cac38d757604d689b5611d8aafc8cf4f (diff)
downloadaur-7209f4f06a7fdcf7599258f99c4087f8117d1da8.tar.gz
update to 1.5.6
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
-rw-r--r--changelog.md139
3 files changed, 145 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 70029712218a..758b60b46be5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-akshare
pkgdesc = Financial data interface library
- pkgver = 1.4.84
+ pkgver = 1.5.6
pkgrel = 1
url = https://github.com/akfamily/akshare
changelog = changelog.md
@@ -31,7 +31,7 @@ pkgbase = python-akshare
depends = python-tabulate
depends = python-decorator
depends = python-pyminiracer
- source = python-akshare-1.4.84.tar.gz::https://github.com/akfamily/akshare/archive/release-v1.4.84.tar.gz
- sha256sums = ee5cd4c85e296c9abe42e34706650c5d86fdd912bd746083e5db4706bfae60b9
+ source = python-akshare-1.5.6.tar.gz::https://github.com/akfamily/akshare/archive/release-v1.5.6.tar.gz
+ sha256sums = bcf7a73dda42e78ea68a32ed59e62a7133ae37b2184bf491b86934703a441c95
pkgname = python-akshare
diff --git a/PKGBUILD b/PKGBUILD
index 1eb887506b99..2013dbf5bd94 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Dimitris Kiziridis <ragouel at outlook dot com>
pkgname=python-akshare
-pkgver=1.4.84
+pkgver=1.5.6
pkgrel=1
pkgdesc="Financial data interface library"
arch=('any')
@@ -37,7 +37,7 @@ makedepends=(
'python-recommonmark')
changelog=changelog.md
source=("$pkgname-$pkgver.tar.gz::$url/archive/release-v$pkgver.tar.gz")
-sha256sums=('ee5cd4c85e296c9abe42e34706650c5d86fdd912bd746083e5db4706bfae60b9')
+sha256sums=('bcf7a73dda42e78ea68a32ed59e62a7133ae37b2184bf491b86934703a441c95')
prepare() {
cd "akshare-release-v$pkgver"
@@ -47,13 +47,12 @@ prepare() {
build() {
cd "akshare-release-v$pkgver"
python -m build --wheel --no-isolation
- ( cd docs; make man )
+ make -C docs man
}
package() {
- export PYTHONHASHSEED=0
cd "akshare-release-v$pkgver"
- python -m installer --destdir="$pkgdir/" dist/*.whl
+ PYTHONHASHSEED=0 python -m installer --destdir="$pkgdir/" dist/*.whl
install -Dm644 docs/build/man/akshare.1 -t "$pkgdir/usr/share/man/man1/"
local _site="$(python -c 'import site; print(site.getsitepackages()[0])')"
diff --git a/changelog.md b/changelog.md
index 1c9862baedb5..a665d202ef17 100644
--- a/changelog.md
+++ b/changelog.md
@@ -1,6 +1,101 @@
# [AKShare](https://github.com/akfamily/akshare) 版本更新
-## 接口更新说明
+## 接口更名一览表
+
+| AKShare 版本 | 旧接口名称 | 新接口名称 | 修改日期 |
+|------------|-------------------|-------------------|----------|
+| 1.4.88 | fund_em_new_found | fund_new_found_em | 20220323 |
+| 1.4.86 | fund_em_aum_hist | fund_aum_hist_em | 20220322 |
+| 1.4.86 | fund_em_aum_trend | fund_aum_trend_em | 20220322 |
+| 1.4.86 | fund_em_aum | fund_aum_em | 20220322 |
+
+## 更新说明
+
+1.5.6 add: add macro_china_yw_electronic_index interface
+
+ 1. 新增 macro_china_yw_electronic_index 接口,获取义乌小商品指数-电子元器件数据
+
+1.5.5 add: add macro_global_sox_index interface
+
+ 1. 新增 macro_global_sox_index 接口,获取费城半导体指数数据
+
+1.5.4 add: add macro_china_commodity_price_index interface
+
+ 1. 新增 macro_china_commodity_price_index 接口,获取大宗商品价格数据
+
+1.5.3 add: add macro_china_energy_index interface
+
+ 1. 新增 macro_china_energy_index 接口,获取能源指数数据
+
+1.5.2 add: add macro_china_agricultural_index interface
+
+ 1. 新增 macro_china_agricultural_index 接口,获取农副指数数据
+
+1.5.1 add: add macro_china_agricultural_product interface
+
+ 1. 新增 macro_china_agricultural_product 接口,获取农产品批发价格总指数数据
+
+1.4.99 add: add macro_china_vegetable_basket interface
+
+ 1. 新增 macro_china_vegetable_basket 接口,获取菜篮子产品批发价格指数数据
+
+1.4.98 fix: fix stock_board_industry_hist_em interface
+
+ 1. 修复 stock_board_industry_hist_em 接口,新增 start_date 和 end_date 参数
+
+1.4.97 fix: fix bond_spot_deal interface
+
+ 1. 修复 bond_spot_deal 接口,对异常数据做处理
+
+1.4.96 fix: fix stock_sse_deal_daily interface
+
+ 1. 修复 stock_sse_deal_daily 接口,最近接口调用新的地址
+
+1.4.95 add: add bond_zh_cov_value_analysis interface
+
+ 1. 新增 bond_zh_cov_value_analysis 接口,获取可转债溢价率分析和可转债价值分析数据
+
+1.4.94 add: add macro_china_mobile_number interface
+
+ 1. 新增 macro_china_mobile_number 接口,获取手机出货量数据
+
+1.4.93 add: add macro_china_insurance_income interface
+
+ 1. 新增 macro_china_insurance_income 接口,获取原保险保费收入数据
+
+1.4.92 add: add stock_lhb_hyyyb_em interface
+
+ 1. 新增 stock_lhb_hyyyb_em 接口,获取东方财富网-数据中心-龙虎榜单-每日活跃营业部数据
+
+1.4.91 fix: fix macro_china_new_financial_credit interface
+
+ 1. 修复 macro_china_new_financial_credit 接口,规范返回字段的类型和按时间排序
+
+1.4.90 add: add macro_china_bank_financing interface
+
+ 1. 新增 macro_china_bank_financing 接口,获取银行理财产品发行数量数据
+
+1.4.89 fix: fix stock_us_hist interface
+
+ 1. 修复 stock_us_hist 接口,结果数据根据日期排序
+
+1.4.88 fix: fix fund_new_found_em interface
+
+ 1. 修复 fund_em_new_found 接口命名为 fund_new_found_em 接口
+
+1.4.87 add: add fund_portfolio_industry_allocation_em interface
+
+ 1. 新增 fund_portfolio_industry_allocation_em 接口,获取天天基金网-基金档案-投资组合-行业配置数据
+
+1.4.86 fix: fix rename all interface in fund_aum_em.py
+
+ 1. 修改 fund_em_aum_hist 接口,重名为 fund_aum_hist_em
+ 2. 修改 fund_em_aum_trend 接口,重名为 fund_aum_trend_em
+ 3. 修改 fund_em_aum 接口,重名为 fund_aum_em
+
+1.4.85 add: add fund_portfolio_bond_hold_em interface
+
+ 1. 新增 fund_portfolio_bond_hold_em 接口,获取天天基金网-基金档案-投资组合-债券持仓数据
1.4.84 fix: fix fund_portfolio_change_em interface
@@ -182,6 +277,48 @@
## 版本更新说明
+1.5.6 add: add macro_china_yw_electronic_index interface
+
+1.5.5 add: add macro_global_sox_index interface
+
+1.5.4 add: add macro_china_commodity_price_index interface
+
+1.5.3 add: add macro_china_energy_index interface
+
+1.5.2 add: add macro_china_agricultural_index interface
+
+1.5.1 add: add macro_china_agricultural_product interface
+
+1.4.99 add: add macro_china_vegetable_basket interface
+
+1.4.98 fix: fix stock_board_industry_hist_em interface
+
+1.4.97 fix: fix bond_spot_deal interface
+
+1.4.96 fix: fix stock_sse_deal_daily interface
+
+1.4.95 add: add bond_zh_cov_value_analysis interface
+
+1.4.94 add: add macro_china_mobile_number interface
+
+1.4.93 add: add macro_china_insurance_income interface
+
+1.4.92 add: add stock_lhb_hyyyb_em interface
+
+1.4.91 fix: fix macro_china_new_financial_credit interface
+
+1.4.90 add: add macro_china_bank_financing interface
+
+1.4.89 fix: fix stock_us_hist interface
+
+1.4.88 fix: fix fund_new_found_em interface
+
+1.4.87 add: add fund_portfolio_industry_allocation_em interface
+
+1.4.86 fix: fix rename all interface in fund_aum_em.py
+
+1.4.85 add: add fund_portfolio_bond_hold_em interface
+
1.4.84 fix: fix fund_portfolio_change_em interface
1.4.83 add: add stock_us_code_table_fu interface