summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcqzw5552024-05-11 09:20:32 +0800
committercqzw5552024-05-11 09:20:32 +0800
commitc12a3ec17467fa138a17af2a44d86de53c37ffa5 (patch)
tree1d330da1c5d6d60ea7693837a8044c49e9c6b457
parent991a3865abd1c302c41e7bedc29b26872af6650a (diff)
downloadaur-python-ansiwrap.tar.gz
python 3.12 rebuild
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 70b5a1acdd39..f12e748599c9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-ansiwrap
pkgdesc = textwrap, but savvy to ANSI colors and styles
pkgver = 0.8.4
- pkgrel = 8
+ pkgrel = 9
url = https://github.com/jonathaneunice/ansiwrap
arch = any
license = Apache
@@ -14,9 +14,9 @@ pkgbase = python-ansiwrap
depends = python
source = https://github.com/jonathaneunice/ansiwrap/archive/20e2e8c78a54bdce947e38c069c5eb9c115423ae/python-ansiwrap-20e2e8c78a54bdce947e38c069c5eb9c115423ae.tar.gz
source = python-ansiwrap-no-textwrap3.patch::https://github.com/jonathaneunice/ansiwrap/pull/16.patch
- source = python-ansiwrap-python3.11.patch::https://github.com/jonathaneunice/ansiwrap/pull/19.patch
+ source = python-ansiwrap-python3.12.patch::https://github.com/jonathaneunice/ansiwrap/pull/20.patch
sha512sums = a01f1f1f79c7a84ca63013f6d05e2abeb00135905d1763f1b5d9fe430613c6bb10fbd2e345074e0001a8e7e40f1916d4c3a946da4dbb02fa288277ad441fab00
sha512sums = 54064900875534263a11ddfd013928383dbb2f00f6e3e6b098940bb1159c485439191667b6c742214c10ec84aca8e3cc62cdc3a5d9ea39cb3e2b74f13ad3a4a4
- sha512sums = cd9aa36634ce57243878ea7f5f08fec9ca82d4a090a016517c40dfa49a2fe4fed613c73d88906480c42761c09e487107ea0792a48d5ac36974ac9bcb9174e97c
+ sha512sums = 7f45d129e0b498451188926464cf16132da784a015855df132f4106fc378215f61141879b67dcd520b5072f3f029276b62c780cd1f3d1148962d785e87d50b84
pkgname = python-ansiwrap
diff --git a/PKGBUILD b/PKGBUILD
index fb7a0bea2988..722bb479b28a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=python-ansiwrap
pkgver=0.8.4
_commit=20e2e8c78a54bdce947e38c069c5eb9c115423ae
-pkgrel=8
+pkgrel=9
pkgdesc="textwrap, but savvy to ANSI colors and styles"
url="https://github.com/jonathaneunice/ansiwrap"
license=('Apache')
@@ -13,14 +13,14 @@ makedepends=('python-setuptools' 'python-build' 'python-installer' 'python-wheel
checkdepends=('python-pytest' 'python-ansicolors')
source=("https://github.com/jonathaneunice/ansiwrap/archive/$_commit/$pkgname-$_commit.tar.gz"
$pkgname-no-textwrap3.patch::https://github.com/jonathaneunice/ansiwrap/pull/16.patch
- $pkgname-python3.11.patch::https://github.com/jonathaneunice/ansiwrap/pull/19.patch)
+ $pkgname-python3.12.patch::https://github.com/jonathaneunice/ansiwrap/pull/20.patch)
sha512sums=('a01f1f1f79c7a84ca63013f6d05e2abeb00135905d1763f1b5d9fe430613c6bb10fbd2e345074e0001a8e7e40f1916d4c3a946da4dbb02fa288277ad441fab00'
'54064900875534263a11ddfd013928383dbb2f00f6e3e6b098940bb1159c485439191667b6c742214c10ec84aca8e3cc62cdc3a5d9ea39cb3e2b74f13ad3a4a4'
- 'cd9aa36634ce57243878ea7f5f08fec9ca82d4a090a016517c40dfa49a2fe4fed613c73d88906480c42761c09e487107ea0792a48d5ac36974ac9bcb9174e97c')
+ '7f45d129e0b498451188926464cf16132da784a015855df132f4106fc378215f61141879b67dcd520b5072f3f029276b62c780cd1f3d1148962d785e87d50b84')
prepare() {
cd ansiwrap-$_commit
- patch -p1 -i ../$pkgname-python3.11.patch
+ patch -p1 -i ../$pkgname-python3.12.patch
patch -p1 -i ../$pkgname-no-textwrap3.patch
sed -i 's/import textwrap3 as textwrap/import textwrap/' test/test_ansiwrap.py
sed -i 's/textwrap3/textwrap/' ansiwrap/core.py