summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-01-09 11:22:50 -0500
committerCarlos Aznarán Laos2022-01-09 11:22:50 -0500
commite2de38dced69f87e500516fc742ae51c3e5dff97 (patch)
tree0272b6dbf515b824bf2ac6fbb67a295c19f7a52c
parent6effe650d0acb6f27716b7f679b2ce2a5986d9f3 (diff)
downloadaur-python-anyconfig-git.tar.gz
Drop python2 support
-rw-r--r--.SRCINFO29
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD62
3 files changed, 48 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1b7592584ad2..5eee7faa2087 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,30 @@
pkgbase = python-anyconfig-git
pkgdesc = Generic access to configuration files in any formats (to be in the future)
- pkgver = 0.9.11.r0.ga24c2c2
+ pkgver = 0.12.0.r0.g09af1950
pkgrel = 1
url = https://github.com/ssato/python-anyconfig
arch = any
license = MIT
- checkdepends = python-tox
- makedepends = python
makedepends = python-setuptools
- makedepends = python2
- makedepends = python2-setuptools
+ makedepends = git
+ depends = python-toml
+ depends = python-ruamel-yaml
+ depends = python-jinja
+ depends = python-jmespath
+ depends = python-jsonschema
+ optdepends = python-simplejson: Replace standard json backend
+ optdepends = python-yaml: YAML support if ruamel.yaml is not aviliable
+ optdepends = python-anyconfig-bson-backend: BSON support using pymongo
+ optdepends = python-anyconfig-ion-backend: Amazon ion load and dump support
+ optdepends = python-anyconfig-cbor-backend: CBOR support using cbor
+ optdepends = python-anyconfig-cbor2-backend: CBOR support using cbor2
+ optdepends = python-anyconfig-configobj-backend: ConfigObj load and dump support
+ optdepends = python-anyconfig-msgpack-backend: MessagePack load and dump support
+ optdepends = python-anyconfig-json5-backend: Json5 load and dump support
+ optdepends = python-anyconfig-fortios-backend: Fortios load and parse support
provides = python-anyconfig
- provides = python2-anyconfig
conflicts = python-anyconfig
- conflicts = python2-anyconfig
source = python-anyconfig::git+https://github.com/ssato/python-anyconfig
sha256sums = SKIP
pkgname = python-anyconfig-git
- depends = python
-
-pkgname = python2-anyconfig-git
- depends = python2
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f59ec20aabf5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index b1c3b9dfe5b4..71c56b7cbb93 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,47 +1,45 @@
# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
-pkgbase='python-anyconfig-git'
-pkgname=('python-anyconfig-git' 'python2-anyconfig-git')
-pkgver=0.9.11.r0.ga24c2c2
+_base=python-anyconfig
+pkgname=${_base}-git
+pkgver=0.12.0.r0.g09af1950
pkgrel=1
-pkgdesc='Generic access to configuration files in any formats (to be in the future)'
-url='https://github.com/ssato/python-anyconfig'
+pkgdesc="Generic access to configuration files in any formats (to be in the future)"
+url="https://github.com/ssato/${_base}"
arch=('any')
-license=('MIT')
-provides=('python-anyconfig' 'python2-anyconfig')
-conflicts=('python-anyconfig' 'python2-anyconfig')
-makedepends=('python'
- 'python-setuptools'
- 'python2'
- 'python2-setuptools')
-checkdepends=('python-tox')
-source=("${pkgname%-git}::git+https://github.com/ssato/python-anyconfig")
+license=(MIT)
+provides=("${_base}")
+conflicts=("${_base}")
+depends=(python-toml python-ruamel-yaml python-jinja python-jmespath python-jsonschema)
+makedepends=(python-setuptools git)
+optdepends=(
+ 'python-simplejson: Replace standard json backend'
+ 'python-yaml: YAML support if ruamel.yaml is not aviliable'
+ 'python-anyconfig-bson-backend: BSON support using pymongo'
+ 'python-anyconfig-ion-backend: Amazon ion load and dump support'
+ 'python-anyconfig-cbor-backend: CBOR support using cbor'
+ 'python-anyconfig-cbor2-backend: CBOR support using cbor2'
+ 'python-anyconfig-configobj-backend: ConfigObj load and dump support'
+ 'python-anyconfig-msgpack-backend: MessagePack load and dump support'
+ 'python-anyconfig-json5-backend: Json5 load and dump support'
+ 'python-anyconfig-fortios-backend: Fortios load and parse support'
+)
+source=(${_base}::git+${url})
sha256sums=('SKIP')
pkgver() {
- cd python-anyconfig
+ cd ${_base}
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' | sed 's/RELEASE_//'
}
build() {
- cd python-anyconfig
+ cd ${_base}
python setup.py build
- python2 setup.py build
}
-package_python-anyconfig-git() {
- depends=('python')
- cd python-anyconfig
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
- install -Dm644 LICENSE.MIT "${pkgdir}/usr/share/licenses/python-anyconfig-git/LICENSE"
+package() {
+ cd ${_base}
+ export PYTHONHASHSEED=0
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm 644 LICENSE.MIT -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
-
-package_python2-anyconfig-git() {
- depends=('python2')
- cd python-anyconfig
- python2 setup.py install --root="${pkgdir}" --optimize=1 --skip-build
- mv "${pkgdir}/usr/bin/anyconfig_cli" "${pkgdir}/usr/bin/anyconfig_cli2"
- mv "${pkgdir}/usr/share/man/man1/anyconfig_cli.1" "${pkgdir}/usr/share/man/man1/anyconfig_cli2.1"
- install -Dm644 LICENSE.MIT "${pkgdir}/usr/share/licenses/python2-anyconfig-git/LICENSE"
-}
-# vim:set ft=sh ts=2 sw=2 et: \ No newline at end of file