summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2024-05-08 13:32:03 -0400
committerGuillaume Horel2024-05-08 13:32:03 -0400
commit9788c44b59c59cf697eff33f78aee41ce2202f6e (patch)
tree6899ce13ceea917db3ab5c4438037ee6e47c22e8
parent69b139dc6fd1be8ae0194d412996b36c2dd0027c (diff)
downloadaur-python-arch.tar.gz
bump to 7.0.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
2 files changed, 13 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 70c7db8dda49..e7de57f6177c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-arch
pkgdesc = ARCH models in Python.
- pkgver = 6.2.0
+ pkgver = 7.0.0
pkgrel = 1
url = https://pypi.python.org/pypi/arch
arch = x86_64
@@ -10,7 +10,6 @@ pkgbase = python-arch
checkdepends = python-matplotlib
checkdepends = jupyter-nbconvert
checkdepends = jupyter-nbformat
- checkdepends = python-property-cached
checkdepends = python-seaborn
makedepends = cython
makedepends = python-build
@@ -18,11 +17,10 @@ pkgbase = python-arch
makedepends = python-setuptools
makedepends = python-setuptools-scm
makedepends = python-wheel
- depends = python-oldest-supported-numpy
depends = python-pandas
depends = python-scipy
depends = python-statsmodels
- source = python-arch-6.2.0.tar.gz::https://files.pythonhosted.org/packages/source/a/arch/arch-6.2.0.tar.gz
- sha256sums = 1b973418e5e672023748a164eada49e3b2374d20d126fae945fecbe75944fe0d
+ source = python-arch-7.0.0.tar.gz::https://files.pythonhosted.org/packages/source/a/arch/arch-7.0.0.tar.gz
+ sha256sums = 353c0dba5242287b8b6b587a70250d788436630bf3b7ef6106f577e45d1ec247
pkgname = python-arch
diff --git a/PKGBUILD b/PKGBUILD
index 0477d66c47da..adefd0d35395 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,28 @@
# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
pkgname='python-arch'
_module='arch'
-pkgver='6.2.0'
+pkgver='7.0.0'
pkgrel=1
pkgdesc="ARCH models in Python."
url="https://pypi.python.org/pypi/arch"
-depends=('python-oldest-supported-numpy'
- 'python-pandas'
+depends=('python-pandas'
'python-scipy'
'python-statsmodels')
-checkdepends=('python-jupyter-client' 'python-pytest' 'python-matplotlib' 'jupyter-nbconvert' 'jupyter-nbformat' 'python-property-cached' 'python-seaborn')
+checkdepends=('python-jupyter-client' 'python-pytest' 'python-matplotlib' 'jupyter-nbconvert' 'jupyter-nbformat' 'python-seaborn')
makedepends=('cython' 'python-build' 'python-installer' 'python-setuptools' 'python-setuptools-scm' 'python-wheel')
license=('custom:University of Illinois/NCSA Open Source License')
arch=('x86_64')
source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-${pkgver}.tar.gz")
-sha256sums=('1b973418e5e672023748a164eada49e3b2374d20d126fae945fecbe75944fe0d')
+sha256sums=('353c0dba5242287b8b6b587a70250d788436630bf3b7ef6106f577e45d1ec247')
+
+prepare() {
+ cd "${_module}-${pkgver}"
+ sed -i -e "s/PytestRemovedIn8Warning/PytestDeprecationWarning/g" setup.cfg
+}
build() {
cd "${_module}-${pkgver}"
- python -m build -wn
+ python -m build -wnx
}
package() {