summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bershatsky2023-07-11 12:27:23 +0300
committerDaniel Bershatsky2023-07-11 12:27:23 +0300
commitc17d2405b65fc0a213b019db992d6f7c6251ddaa (patch)
treedbec6198d54af17c6bdfe9b2bb553d7f5c6cda9d
parent1d068c5a2a771224a4b6ba481e506b20cf2b2f48 (diff)
downloadaur-python-asciitree.tar.gz
Apply minor fixes
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 90b58fcfa136..61b97586ba29 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = python-asciitree
pkgdesc = Draws +-- ASCII Trees
pkgver = 0.3.3
- pkgrel = 1
+ pkgrel = 2
url = http://github.com/mbr/asciitree
arch = any
license = MIT
- depends = python-build
- depends = python-installer
- depends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-setuptools
+ makedepends = python-wheel
+ depends = python
source = https://files.pythonhosted.org/packages/source/a/asciitree/asciitree-0.3.3.tar.gz
sha256sums = 4aa4b9b649f85e3fcb343363d97564aa1fb62e249677f2e18a96765145cc0f6e
diff --git a/PKGBUILD b/PKGBUILD
index 15b4b4accc94..306164d36729 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_name=asciitree
pkgname=python-asciitree
pkgver=0.3.3
-pkgrel=1
+pkgrel=2
pkgdesc='Draws +-- ASCII Trees'
arch=('any')
url='http://github.com/mbr/asciitree'
@@ -14,14 +14,12 @@ source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_nam
sha256sums=('4aa4b9b649f85e3fcb343363d97564aa1fb62e249677f2e18a96765145cc0f6e')
build() {
- cd "$_name-$pkgver"
- python -m build -n -w
+ python -m build -nw $_name-$pkgver
}
package() {
- cd "$_name-$pkgver"
python -m installer \
--compile-bytecode 1 \
--destdir $pkgdir \
- dist/${_name}-${pkgver}-*.whl
+ $_name-$pkgver/dist/${_name}-${pkgver}-*.whl
}