summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPumpkinCheshire2022-05-24 09:48:46 +0800
committerPumpkinCheshire2022-05-24 09:48:46 +0800
commit422f435bbe8bd829261cf17f43708c6225962097 (patch)
treeeccdddb2ca693e3d23f340426f0d7754a16b145d
parent4d9b4476c80e72d28ff3ba4cf1849784af175b34 (diff)
downloadaur-python-astpretty.tar.gz
bump to 3.0.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD28
2 files changed, 24 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1fc2bf2e70e4..b522cdde4a8f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = python-astpretty
pkgdesc = Pretty print the output of python stdlib 'ast.parse'.
- pkgver = 2.1.0
+ pkgver = 3.0.0
pkgrel = 1
url = https://github.com/asottile/astpretty
arch = any
license = MIT
- makedepends = python-setuptools
+ makedepends = python-wheel
+ makedepends = python-build
+ makedepends = python-installer
depends = python
- source = https://files.pythonhosted.org/packages/source/a/astpretty/astpretty-2.1.0.tar.gz
- b2sums = 9e96eb963eee5b68d609bea6b4db231f3bf9589674520ad880868a105e80bf40837ad7b24c81d1a1c0c451e75cbcae5fd4b9a76ec7f1e2087600de67e42d666d
+ source = https://files.pythonhosted.org/packages/source/a/astpretty/astpretty-3.0.0.tar.gz
+ b2sums = cb5cba1efbd3b44963271c80410fba47caa65d8cf0122bbf25a5472b9c415a17e0a4132b0236be4cee7225a77aaa122c9a9fbf4abd61865630786fb63e67d649
pkgname = python-astpretty
diff --git a/PKGBUILD b/PKGBUILD
index f68173bd76a5..1f7720005ced 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,34 @@
-# Maintainer: PumpkinCheshire <me at pumpkincheshire dot top>
+#!/bin/bash
+
+# Maintainer: PumpkinCheshire <me at pumpkincheshire dot com>
pkgname=python-astpretty
_name=astpretty
-pkgver=2.1.0
+pkgver=3.0.0
pkgrel=1
pkgdesc="Pretty print the output of python stdlib 'ast.parse'."
arch=('any')
url="https://github.com/asottile/astpretty"
license=('MIT')
depends=('python')
-makedepends=('python-setuptools')
+makedepends=(
+ 'python-wheel'
+ 'python-build'
+ 'python-installer'
+)
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-b2sums=('9e96eb963eee5b68d609bea6b4db231f3bf9589674520ad880868a105e80bf40837ad7b24c81d1a1c0c451e75cbcae5fd4b9a76ec7f1e2087600de67e42d666d')
+b2sums=('cb5cba1efbd3b44963271c80410fba47caa65d8cf0122bbf25a5472b9c415a17e0a4132b0236be4cee7225a77aaa122c9a9fbf4abd61865630786fb63e67d649')
build() {
- cd "$_name-$pkgver"
- export PYTHONHASHSEED=0
- python setup.py build
+ cd "$srcdir/$_name-$pkgver" || exit
+
+ python -m build --wheel --no-isolation
}
package() {
- cd "$_name-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "$srcdir/$_name-$pkgver" || exit
+
+ python -m installer --destdir="$pkgdir" dist/*.whl
+
+ # install -Dm644 LICENCE.txt -t "$pkgdir/usr/share/licenses/$pkgname"
}