summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrkcf2019-04-09 13:05:42 -0700
committerrkcf2019-04-09 13:05:42 -0700
commit332dc5c918831fd73b7bc1473876d0800a9dcab0 (patch)
treee4e44d76b3342f71bce388621c7e55502585a962
downloadaur-python-astunparse.tar.gz
initial commit python-astunparse v1.6.2
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a2c57dcb718c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-astunparse
+ pkgdesc = An AST unparser for Python
+ pkgver = 1.6.2
+ pkgrel = 1
+ url = https://github.com/simonpercivall/astunparse
+ arch = any
+ license = python
+ makedepends = python-setuptools
+ makedepends = python-wheel
+ depends = python
+ depends = python-six
+ source = https://github.com/simonpercivall/astunparse/archive/v1.6.2.tar.gz
+ md5sums = ca13543cfcdac7dbfd3ff936c0affbf1
+
+pkgname = python-astunparse
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b55d1839e2aa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Andrew Steinke <rkcf@rkcf.me>
+
+pkgname=python-astunparse
+_pkgname=astunparse
+pkgrel=1
+pkgver=1.6.2
+pkgdesc="An AST unparser for Python"
+depends=('python' 'python-six')
+makedepends=('python-setuptools' 'python-wheel')
+url="https://github.com/simonpercivall/astunparse"
+license=('python')
+arch=('any')
+source=("$url/archive/v$pkgver.tar.gz")
+md5sums=('ca13543cfcdac7dbfd3ff936c0affbf1')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: