summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKokaKiwi2021-09-29 23:51:04 +0200
committerKokaKiwi2021-09-29 23:51:04 +0200
commit142ef424a535fbc2e7192d09f8ea54db10c011bf (patch)
tree562ede55de6487a0e0cfc1e63049cc8a8554cef7
parent826a5145fa13c4526fbff66afdc46735a8641173 (diff)
downloadaur-python-autokernel.tar.gz
Update: 0.9.9
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
2 files changed, 15 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f1ad4419670d..b7875beeb3ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,20 @@
pkgbase = python-autokernel
pkgdesc = A tool to autodetect and manage kernel configuration options
- pkgver = 0.9.6
+ pkgver = 0.9.9
pkgrel = 1
url = https://autokernel.oddlama.org/
arch = any
license = MIT
makedepends = python-setuptools
+ makedepends = python-pbr
depends = python
depends = python-kconfiglib
depends = python-lark-parser
depends = python-dateutil
depends = python-requests
depends = python-sympy
- source = python-autokernel-0.9.6.tar.gz::https://github.com/oddlama/autokernel/archive/v0.9.6.tar.gz
- sha256sums = 2041696daf430973c6432dcbc69fdd058d68f8bc3b3983e505c88cd41d8d6759
- b2sums = eed32796a8d0521076d65602d1edab4d52f1b08d7095589947bca6156f7b14c8363cffa7e818eeb8d203794df13cf84294d912b1d61b114553475a307147a4f7
+ source = python-autokernel-0.9.9.tar.gz::https://files.pythonhosted.org/packages/source/a/autokernel/autokernel-0.9.9.tar.gz
+ sha256sums = 405959337a58f9a9d7e89a5ba211e7e22b16b3c1fac0ba29c3683ba55625cc45
+ b2sums = 722615bf3f1222ba610fc8db894018bbb9946b05455adf29f4c86430409370b7e3fd356484a69887dae2c11724141654369cad125b349686b43c1920a0f7975b
pkgname = python-autokernel
-
diff --git a/PKGBUILD b/PKGBUILD
index 36b117f2b63a..bad33633058b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=autokernel
pkgname="python-${_pkgname}"
-pkgver=0.9.6
+pkgver=0.9.9
pkgrel=1
pkgdesc="A tool to autodetect and manage kernel configuration options"
arch=('any')
@@ -11,10 +11,10 @@ license=('MIT')
depends=('python'
'python-kconfiglib' 'python-lark-parser' 'python-dateutil'
'python-requests' 'python-sympy')
-makedepends=('python-setuptools')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/oddlama/autokernel/archive/v${pkgver}.tar.gz")
-sha256sums=('2041696daf430973c6432dcbc69fdd058d68f8bc3b3983e505c88cd41d8d6759')
-b2sums=('eed32796a8d0521076d65602d1edab4d52f1b08d7095589947bca6156f7b14c8363cffa7e818eeb8d203794df13cf84294d912b1d61b114553475a307147a4f7')
+makedepends=('python-setuptools' 'python-pbr')
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkgname::1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
+sha256sums=('405959337a58f9a9d7e89a5ba211e7e22b16b3c1fac0ba29c3683ba55625cc45')
+b2sums=('722615bf3f1222ba610fc8db894018bbb9946b05455adf29f4c86430409370b7e3fd356484a69887dae2c11724141654369cad125b349686b43c1920a0f7975b')
build() {
cd "${_pkgname}-${pkgver}"
@@ -26,5 +26,10 @@ package() {
cd "${_pkgname}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1
+
+ install -Dm0644 -t "${pkgdir}/usr/lib"/python*"/site-packages/autokernel/contrib" \
+ autokernel/contrib/{config.lark,internal.conf}
+ chmod -R +r "$pkgdir/usr/lib"/python*"/site-packages"
+
install -Dm0644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}