summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKelsey Maes2019-03-13 18:42:30 -0700
committerKelsey Maes2019-03-13 18:42:30 -0700
commit38c36628b52e1bafb385f1d784f234b39b6b483e (patch)
tree2e26df795bf3b79fb5fd2c3d6c243df368ecdda0
parent621110f3ff1d79248b7814b97317819dd0da2ade (diff)
downloadaur-38c36628b52e1bafb385f1d784f234b39b6b483e.tar.gz
Update to 2.0.60
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
-rw-r--r--wheel.patch40
3 files changed, 6 insertions, 52 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8f28d2f8c825..bb3e0763174e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-azure-cli
pkgdesc = Microsoft Azure Command-Line Tools
- pkgver = 2.0.52
+ pkgver = 2.0.60
pkgrel = 1
url = https://github.com/Azure/azure-cli
arch = any
@@ -22,10 +22,8 @@ pkgbase = python-azure-cli
depends = python-vsts-cd-manager
depends = python-wheel
depends = python-yaml
- source = https://github.com/Azure/azure-cli/archive/azure-cli-2.0.52.tar.gz
- source = wheel.patch
- sha256sums = 4fe43b7eff3212aace6906505e1cec7cb06b7626da757d1890c6e1c5e82218bd
- sha256sums = 33450e8feaa7bb20a5e64ef628c88ddf998d88c302b6f85458c319f68c167dfd
+ source = https://github.com/Azure/azure-cli/archive/azure-cli-2.0.60.tar.gz
+ sha256sums = f3919f0e1cb7a6344cc65c7595491dc7caccd38e000cce13bc51f8a92685d121
pkgname = python-azure-cli
diff --git a/PKGBUILD b/PKGBUILD
index 8eb1237ba741..5d2e0071b088 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_name=azure-cli
pkgname=python-$_name
-pkgver=2.0.52
+pkgver=2.0.60
pkgrel=1
pkgdesc="Microsoft Azure Command-Line Tools"
arch=('any')
@@ -13,16 +13,12 @@ depends=('python-applicationinsights' 'python-argcomplete' 'python-azure'
'python-pyopenssl' 'python-pytz' 'python-scp' 'python-sshtunnel'
'python-tabulate' 'python-vsts-cd-manager' 'python-wheel' 'python-yaml')
makedepends=('git' 'python-setuptools')
-source=("https://github.com/Azure/azure-cli/archive/azure-cli-${pkgver}.tar.gz"
- "wheel.patch")
-sha256sums=('4fe43b7eff3212aace6906505e1cec7cb06b7626da757d1890c6e1c5e82218bd'
- '33450e8feaa7bb20a5e64ef628c88ddf998d88c302b6f85458c319f68c167dfd')
+source=("https://github.com/Azure/azure-cli/archive/azure-cli-${pkgver}.tar.gz")
+sha256sums=('f3919f0e1cb7a6344cc65c7595491dc7caccd38e000cce13bc51f8a92685d121')
build() {
cd "$_name-$_name-$pkgver/src"
- patch -p2 < ../../wheel.patch
-
for d in azure-cli \
azure-cli-core \
azure-cli-nspkg \
diff --git a/wheel.patch b/wheel.patch
deleted file mode 100644
index 5c53f460f8e7..000000000000
--- a/wheel.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-diff -crB azure-cli-azure-cli-2.0.52/src/azure-cli-core/azure/cli/core/extension/operations.py azure-cli-azure-cli-2.0.52_fixed/src/azure-cli-core/azure/cli/core/extension/operations.py
-*** azure-cli-azure-cli-2.0.52/src/azure-cli-core/azure/cli/core/extension/operations.py 2018-11-29 13:32:10.000000000 -0800
---- azure-cli-azure-cli-2.0.52_fixed/src/azure-cli-core/azure/cli/core/extension/operations.py 2019-01-01 10:40:31.594122272 -0800
-***************
-*** 14,20 ****
- from collections import OrderedDict
-
- import requests
-! from wheel.install import WHEEL_INFO_RE
- from pkg_resources import parse_version
-
- from knack.log import get_logger
---- 14,20 ----
- from collections import OrderedDict
-
- import requests
-! from wheel.wheelfile import WHEEL_INFO_RE
- from pkg_resources import parse_version
-
- from knack.log import get_logger
-diff -crB azure-cli-azure-cli-2.0.52/src/azure-cli-core/azure/cli/core/extension/_resolve.py azure-cli-azure-cli-2.0.52_fixed/src/azure-cli-core/azure/cli/core/extension/_resolve.py
-*** azure-cli-azure-cli-2.0.52/src/azure-cli-core/azure/cli/core/extension/_resolve.py 2018-11-29 13:32:10.000000000 -0800
---- azure-cli-azure-cli-2.0.52_fixed/src/azure-cli-core/azure/cli/core/extension/_resolve.py 2019-01-01 10:40:46.814055369 -0800
-***************
-*** 2,8 ****
- # Copyright (c) Microsoft Corporation. All rights reserved.
- # Licensed under the MIT License. See License.txt in the project root for license information.
- # --------------------------------------------------------------------------------------------
-! from wheel.install import WHEEL_INFO_RE
- from pkg_resources import parse_version
-
- from knack.log import get_logger
---- 2,8 ----
- # Copyright (c) Microsoft Corporation. All rights reserved.
- # Licensed under the MIT License. See License.txt in the project root for license information.
- # --------------------------------------------------------------------------------------------
-! from wheel.wheelfile import WHEEL_INFO_RE
- from pkg_resources import parse_version
-
- from knack.log import get_logger