summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKelsey Maes2017-03-19 21:07:44 -0700
committerKelsey Maes2017-03-19 21:07:44 -0700
commit7cdc7caa23f8691e7822056e602816f0907cd816 (patch)
tree16e4834d1bb656136cbe319444f65711a8c9373f
parentae122b28de69070ac71fab5f863c367ec59cb010 (diff)
downloadaur-7cdc7caa23f8691e7822056e602816f0907cd816.tar.gz
Add most of the CLI submodules
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD8
2 files changed, 26 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df38ff8fff99..2a3c71140851 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,7 +6,25 @@ pkgbase = python-azure-cli
arch = any
license = MIT
makedepends = python-setuptools
- depends = python-azure-cli-core
+ depends = python-azure-cli-acs
+ depends = python-azure-cli-appservice
+ depends = python-azure-cli-batch
+ depends = python-azure-cli-cloud
+ depends = python-azure-cli-component
+ depends = python-azure-cli-configure
+ depends = python-azure-cli-container
+ depends = python-azure-cli-documentdb
+ depends = python-azure-cli-find
+ depends = python-azure-cli-iot
+ depends = python-azure-cli-keyvault
+ depends = python-azure-cli-network
+ depends = python-azure-cli-profile
+ depends = python-azure-cli-redis
+ depends = python-azure-cli-resource
+ depends = python-azure-cli-role
+ depends = python-azure-cli-sql
+ depends = python-azure-cli-storage
+ depends = python-azure-cli-vm
source = https://files.pythonhosted.org/packages/source/a/azure-cli/azure-cli-2.0.1.tar.gz
md5sums = f1eb3c2a9f6ac008d2741c6e37b066c4
diff --git a/PKGBUILD b/PKGBUILD
index 797c7ddc7ab6..590f81c034c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,13 @@ pkgdesc="Microsoft Azure Command-Line Tools"
arch=('any')
url="https://github.com/Azure/azure-cli"
license=('MIT')
-depends=('python-azure-cli-core')
+depends=('python-azure-cli-acs' 'python-azure-cli-appservice' 'python-azure-cli-batch'
+ 'python-azure-cli-cloud' 'python-azure-cli-component' 'python-azure-cli-configure'
+ 'python-azure-cli-container' 'python-azure-cli-documentdb' 'python-azure-cli-find'
+ 'python-azure-cli-iot' 'python-azure-cli-keyvault' 'python-azure-cli-network'
+ 'python-azure-cli-profile' 'python-azure-cli-redis' 'python-azure-cli-resource'
+ 'python-azure-cli-role' 'python-azure-cli-sql' 'python-azure-cli-storage'
+ 'python-azure-cli-vm')
makedepends=('python-setuptools')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
md5sums=('f1eb3c2a9f6ac008d2741c6e37b066c4')