summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKelsey Maes2017-05-01 22:38:41 -0700
committerKelsey Maes2017-05-01 22:38:41 -0700
commit02744b641e4dd3233573f5bae278facc64335add (patch)
treefc293131b6425c3298c9fe8daa7526b2b64b5ef7
downloadaur-python-azure-cli-acr.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD33
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a458b8d883c0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-azure-cli-acr
+ pkgdesc = Microsoft Azure Command-Line Tools ACR Command Module
+ pkgver = 2.0.2
+ pkgrel = 1
+ url = https://github.com/Azure/azure-cli
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-azure-cli-core
+ depends = python-azure
+ depends = python-azure-cli-command-modules-nspkg
+ source = https://files.pythonhosted.org/packages/source/a/azure-cli-acr/azure-cli-acr-2.0.2.tar.gz
+ md5sums = 96b6bf6b8fc11cd258fe653148c8b4fd
+
+pkgname = python-azure-cli-acr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d7cd34840dcd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Kelsey Maes <kelseymaes at outlook dot com>
+
+_name=azure-cli-acr
+pkgname=python-$_name
+pkgver=2.0.2
+pkgrel=1
+pkgdesc="Microsoft Azure Command-Line Tools ACR Command Module"
+arch=('any')
+url="https://github.com/Azure/azure-cli"
+license=('MIT')
+depends=('python-azure-cli-core' 'python-azure' 'python-azure-cli-command-modules-nspkg')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+md5sums=('96b6bf6b8fc11cd258fe653148c8b4fd')
+
+build() {
+ cd "$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+
+ rm "$pkgdir"/usr/lib/python3.?/site-packages/azure/__init__.py
+ rm "$pkgdir"/usr/lib/python3.?/site-packages/azure/__pycache__/__init__.*
+
+ rm "$pkgdir"/usr/lib/python3.?/site-packages/azure/cli/__init__.py
+ rm "$pkgdir"/usr/lib/python3.?/site-packages/azure/cli/__pycache__/__init__.*
+
+ rm "$pkgdir"/usr/lib/python3.?/site-packages/azure/cli/command_modules/__init__.py
+ rm "$pkgdir"/usr/lib/python3.?/site-packages/azure/cli/command_modules/__pycache__/__init__.*
+}