summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKelsey Maes2017-05-01 22:42:18 -0700
committerKelsey Maes2017-05-01 22:42:18 -0700
commit05819085d3e77404b84df7acd59dce051fcc2d59 (patch)
treee5391a26eecb1e7d1e155da60275b99fc3ec02a8
parent08d023cba4af170de80ebd484fbb1100171abe54 (diff)
downloadaur-python-azure-cli-cloud.tar.gz
2.0.4 update
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD15
2 files changed, 16 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 294e13c63a43..7c1948bc8e10 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = python-azure-cli-cloud
pkgdesc = Microsoft Azure Command-Line Tools Cloud Command Module
- pkgver = 2.0.0
+ pkgver = 2.0.2
pkgrel = 1
url = https://github.com/Azure/azure-cli
arch = any
license = MIT
makedepends = python-setuptools
+ depends = python-azure-cli-command-modules-nspkg
depends = python-azure-cli-core
- source = https://files.pythonhosted.org/packages/source/a/azure-cli-cloud/azure-cli-cloud-2.0.0.tar.gz
- md5sums = 17b6823a9d84f09d4a68e96cb202dbdf
+ source = https://files.pythonhosted.org/packages/source/a/azure-cli-cloud/azure-cli-cloud-2.0.2.tar.gz
+ md5sums = 45aa63257cc4483804d030c0e39f473d
pkgname = python-azure-cli-cloud
diff --git a/PKGBUILD b/PKGBUILD
index da3597e316fc..47c3461bffa6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,16 @@
_name=azure-cli-cloud
pkgname=python-$_name
-pkgver=2.0.0
+pkgver=2.0.2
pkgrel=1
pkgdesc="Microsoft Azure Command-Line Tools Cloud Command Module"
arch=('any')
url="https://github.com/Azure/azure-cli"
license=('MIT')
-depends=('python-azure-cli-core')
+depends=('python-azure-cli-command-modules-nspkg' 'python-azure-cli-core')
makedepends=('python-setuptools')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-md5sums=('17b6823a9d84f09d4a68e96cb202dbdf')
+md5sums=('45aa63257cc4483804d030c0e39f473d')
build() {
cd "$_name-$pkgver"
@@ -21,4 +21,13 @@ build() {
package() {
cd "$_name-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1
+
+ rm "$pkgdir"/usr/lib/python3.?/site-packages/azure/__init__.py
+ rm "$pkgdir"/usr/lib/python3.?/site-packages/azure/__pycache__/__init__.*
+
+ rm "$pkgdir"/usr/lib/python3.?/site-packages/azure/cli/__init__.py
+ rm "$pkgdir"/usr/lib/python3.?/site-packages/azure/cli/__pycache__/__init__.*
+
+ rm "$pkgdir"/usr/lib/python3.?/site-packages/azure/cli/command_modules/__init__.py
+ rm "$pkgdir"/usr/lib/python3.?/site-packages/azure/cli/command_modules/__pycache__/__init__.*
}