summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjuacrumar2022-04-07 09:40:42 +0200
committerjuacrumar2022-04-07 09:40:42 +0200
commit1dcc2d0cf63c4792f6a504fed61518cda8645ffc (patch)
tree090f234cf0d6c5059fa1f168fc63507574076532
downloadaur-python-banana-hep.tar.gz
first commit for banana-hep, version 0.6.5
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD43
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d3751e27efc0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = python-banana-hep
+ pkgdesc = Benchmarking infrastructure and utilities for Deep Inelastic Scattering and evolution codes used in High Energy Physics.
+ pkgver = 0.6.5
+ pkgrel = 1
+ url = https://banana-hep.readthedocs.io/
+ arch = any
+ license = GPL-3
+ makedepends = python-setuptools
+ depends = python>=3.8
+ depends = python-click
+ depends = python-matplotlib
+ depends = python-numpy
+ depends = python-pandas
+ depends = python-pendulum
+ depends = python-yaml
+ depends = python-rich
+ depends = python-sqlalchemy
+ optdepends = lhapdf: provides PDF files in the LHAPDF format
+ optdepends = python-eko: Python module to solve the DGLAP equations
+ provides = python-banana-hep
+ source = https://pypi.io/packages/source/b/banana-hep/banana-hep-0.6.5.tar.gz
+ md5sums = 8b3786476df0fcc06996cddb24a7fcbe
+
+pkgname = python-banana-hep
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d25065b44d6e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Juacrumar <juacrumar at lairen dot eu>
+
+pkgname=python-banana-hep
+_name=banana-hep
+pkgver=0.6.5
+pkgrel=1
+pkgdesc='Benchmarking infrastructure and utilities for Deep Inelastic Scattering and evolution codes used in High Energy Physics.'
+arch=('any')
+url="https://banana-hep.readthedocs.io/"
+license=('GPL-3')
+makedepends=("python-setuptools")
+depends=("python>=3.8"
+ "python-click"
+ "python-matplotlib"
+ "python-numpy"
+ "python-pandas"
+ "python-pendulum"
+ "python-yaml"
+ "python-rich"
+ "python-sqlalchemy"
+ )
+
+optdepends=("lhapdf: provides PDF files in the LHAPDF format"
+ "python-eko: Python module to solve the DGLAP equations"
+ )
+provides=("python-banana-hep")
+changelog=
+source=("https://pypi.io/packages/source/b/${_name}/${_name}-${pkgver}.tar.gz")
+md5sums=("8b3786476df0fcc06996cddb24a7fcbe")
+
+prepare() {
+ cd "$_name-$pkgver"
+}
+
+build() {
+ cd "$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=2 --skip-build
+}