summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSerene-Arc2023-01-31 13:09:55 +1000
committerSerene-Arc2023-01-31 13:09:55 +1000
commitaa060bd56ade7feb0dd88b1441711175fb8fc8bc (patch)
tree12e6f27775275cf9fa723ee41cbd22b0672a1fe5
parent6d7f4dcfa8e40f5b8cbf31ac547c9761dd816a73 (diff)
downloadaur-python-bdfr-git.tar.gz
Update installation process
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD29
2 files changed, 35 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9ca1aaecfd48..afd54047bc26 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,22 @@
pkgbase = python-bdfr-git
pkgdesc = Bulk downloader for Reddit from development branch
- pkgver = 2.6.1.r38.g00c4307
+ pkgver = 2.6.2.r0.g8c293a4
pkgrel = 1
url = https://github.com/aliparlakci/bulk-downloader-for-reddit
arch = any
license = GPL3
makedepends = git
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ makedepends = python-setuptools
depends = python
- depends = python-setuptools
+ depends = python-beautifulsoup4
+ depends = python-dict2xml
+ depends = python-pip
+ depends = python-praw
+ depends = python-yaml
+ depends = yt-dlp
provides = python-bdfr
conflicts = python-bdfr
source = bulk-downloader-for-reddit::git+https://github.com/aliparlakci/bulk-downloader-for-reddit.git#branch=development
diff --git a/PKGBUILD b/PKGBUILD
index 2682b4a22f69..cb719bc25cea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,29 @@
_pkgname="bulk-downloader-for-reddit"
pkgname=python-bdfr-git
-pkgver=2.6.1.r38.g00c4307
+pkgver=2.6.2.r0.g8c293a4
pkgrel=1
pkgdesc="Bulk downloader for Reddit from development branch"
conflicts=('python-bdfr')
provides=('python-bdfr')
arch=('any')
url="https://github.com/aliparlakci/bulk-downloader-for-reddit"
-depends=('python' 'python-setuptools')
-makedepends=('git')
+depends=(
+ 'python'
+ 'python-beautifulsoup4'
+ 'python-dict2xml'
+ 'python-pip'
+ 'python-praw'
+ 'python-yaml'
+ 'yt-dlp'
+)
+makedepends=(
+ 'git'
+ 'python-build'
+ 'python-installer'
+ 'python-wheel'
+ 'python-setuptools'
+)
license=('GPL3')
source=("$_pkgname::git+https://github.com/aliparlakci/bulk-downloader-for-reddit.git#branch=development")
md5sums=('SKIP')
@@ -20,7 +34,12 @@ pkgver() {
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+build() {
+ cd "$_pkgname"
+ python -m build --wheel --no-isolation
+}
+
package() {
- cd "$_pkgname"
- python -m pip install . --root="$pkgdir"
+ cd "$_pkgname"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}