summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHenry-ZHR2025-02-21 14:46:28 +0800
committerHenry-ZHR2025-02-21 14:46:28 +0800
commitde64951729636c2da01a9d0a4a6e8bd6cb1b8c74 (patch)
treec2c9ceae6d0faa9137a88031272573b12639ae2f
parent1c495b831c5deaf3c60aa1f55a1e762221ffbe40 (diff)
downloadaur-python-blendmodes.tar.gz
2025
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD24
2 files changed, 23 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1724033a7f4e..2e5b84d3b9c0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,22 @@
pkgbase = python-blendmodes
pkgdesc = Use this module to apply a number of blending modes to a background and foreground image
- pkgver = 2024.1.1
+ pkgver = 2025
pkgrel = 1
url = https://github.com/FHPythonUtils/BlendModes
arch = any
license = MIT
+ checkdepends = python-pytest
+ checkdepends = python-imgcompare
+ makedepends = git
makedepends = python-build
makedepends = python-installer
- makedepends = python-poetry
+ makedepends = python-hatchling
makedepends = python-wheel
depends = python
depends = python-pillow
depends = python-numpy
depends = python-aenum
- source = https://files.pythonhosted.org/packages/source/b/blendmodes/blendmodes-2024.1.1.tar.gz
- sha512sums = 81d3d904d0164a0798f481d372deb48e651bfa95b623f7f3fe9df814b435b63e1e1e23c91feff6e4ca9957576f351d8a37a10ff1732b9c33e1566bb5ab631487
+ source = python-blendmodes::git+https://github.com/FHPythonUtils/BlendModes.git#tag=74eeb6a4cd887decca66ed23bcf448a964442463
+ sha512sums = SKIP
pkgname = python-blendmodes
diff --git a/PKGBUILD b/PKGBUILD
index 07967ed8b4b2..9243c97fdef6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,6 @@
# Maintainer: Henry-ZHR <henry-zhr@qq.com>
pkgname=python-blendmodes
-_name=${pkgname#python-}
-pkgver=2024.1.1
+pkgver=2025
pkgrel=1
pkgdesc='Use this module to apply a number of blending modes to a background and foreground image'
arch=('any')
@@ -11,20 +10,29 @@ depends=('python'
'python-pillow'
'python-numpy'
'python-aenum')
-makedepends=('python-build'
+makedepends=('git'
+ 'python-build'
'python-installer'
- 'python-poetry'
+ 'python-hatchling'
'python-wheel')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha512sums=('81d3d904d0164a0798f481d372deb48e651bfa95b623f7f3fe9df814b435b63e1e1e23c91feff6e4ca9957576f351d8a37a10ff1732b9c33e1566bb5ab631487')
+checkdepends=('python-pytest'
+ 'python-imgcompare')
+_tag='74eeb6a4cd887decca66ed23bcf448a964442463'
+source=("${pkgname}::git+${url}.git#tag=${_tag}")
+sha512sums=('SKIP')
build() {
- cd "${_name}-${pkgver}"
+ cd "${pkgname}"
python -m build --wheel --no-isolation
}
package() {
- cd "${_name}-${pkgver}"
+ cd "${pkgname}"
python -m installer --destdir="${pkgdir}" dist/*.whl
install -Dm644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
}
+
+check() {
+ cd "${pkgname}"
+ pytest
+}