summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMorgenstern2024-04-28 13:40:26 +1200
committerMorgenstern2024-04-28 13:40:26 +1200
commit9c1f6ed9bfeb7b756e834e83e327167ad8683675 (patch)
tree96314cc7c0acae4b7e814548a9be9306c6e165a0
parent4e39688a6acd3bde404af39cb79ee368aec521a7 (diff)
downloadaur-python-bsdiff4.tar.gz
python-3.12.3 rebuild
Update license array and split LICENSE file for each license type
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD14
2 files changed, 14 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ffc16553a201..a68288611bd7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = python-bsdiff4
pkgdesc = Binary diff and patch using the BSDIFF4-format
pkgver = 1.2.4
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/ilanschnell/bsdiff4
arch = x86_64
- license = BSD
+ license = BSD-3-Clause
+ license = BSD-Protection
makedepends = python-build
makedepends = python-installer
makedepends = python-setuptools
diff --git a/PKGBUILD b/PKGBUILD
index 9b377d3a2929..2c80b497c63f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,11 +3,12 @@
pkgname=python-bsdiff4
pkgver=1.2.4
-pkgrel=1
+pkgrel=2
pkgdesc="Binary diff and patch using the BSDIFF4-format"
arch=('x86_64')
url="https://github.com/ilanschnell/${pkgname##*-}"
-license=('BSD')
+license=('BSD-3-Clause'
+ 'BSD-Protection')
depends=('python')
makedepends=('python-build'
'python-installer'
@@ -24,6 +25,13 @@ build() {
package() {
cd "${pkgname##*-}-${pkgver}"
python -m installer --destdir="${pkgdir}" dist/*.whl
- install -Dm0644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ head -n 28 LICENSE > "LICENSE-${pkgname}"
+ head -n +29 LICENSE > LICENSE-cx_bsdiff
+ rm LICENSE
+ install -vDm0644 "LICENSE-${pkgname}" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-${pkgname}"
+ install -vDm0644 "LICENSE-cx_bsdiff" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE-cx_bsdiff"
}