summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaximilian Weiss2017-11-07 08:45:55 -0800
committerMaximilian Weiss2017-11-07 08:45:55 -0800
commitb8c737252ba9d40ae21d09d09cadd2621e6f3ab6 (patch)
tree8e1263d1f914db4611b73681d130c84f2d6ddd6b
downloadaur-b8c737252ba9d40ae21d09d09cadd2621e6f3ab6.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD34
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d6ad4de554d3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-btchip-git
+ pkgdesc = Python library to communicate with BTChip dongle
+ pkgver = 0.1.22
+ pkgrel = 1
+ url = https://github.com/LedgerHQ/btchip-python
+ arch = any
+ license = Apache
+ makedepends = python-setuptools
+ depends = python-hidapi
+ optdepends = btchip-udev: access BTChip as non-root user
+ provides = python-btchip-git
+ provides = python-btchip
+ conflicts = python-btchip-git
+ conflicts = python-btchip
+ source = git://github.com/LedgerHQ/btchip-python
+ sha256sums = SKIP
+
+pkgname = python-btchip-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8c22bb0db1b1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Maximilian Weiss <$(echo "bWF4QG1heHdlaXNzLmlv" | base64 -d)>
+# Contributor: Timothy Redaelli <timothy.redaelli@gmail.com>
+# Contributor: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=python-btchip-git
+pkgver=0.1.22
+pkgrel=1
+pkgdesc="Python library to communicate with BTChip dongle"
+arch=('any')
+depends=('python-hidapi')
+makedepends=('python-setuptools')
+optdepends=('btchip-udev: access BTChip as non-root user')
+url="https://github.com/LedgerHQ/btchip-python"
+license=('Apache')
+provides=('python-btchip-git' 'python-btchip')
+conflicts=('python-btchip-git' 'python-btchip')
+source=(git://github.com/LedgerHQ/btchip-python)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/btchip-python/"
+ git describe --abbrev=0 --tags | head -n 1 | sed 's/v//g'
+}
+
+build() {
+ cd "$srcdir/btchip-python/"
+ git checkout $(git describe --abbrev=0 --tags | head -n 1) > /dev/null 2>&1
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/btchip-python/"
+ python setup.py install --root="$pkgdir" --optimize=1
+}