summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-05-16 21:13:09 -0500
committerLuis Martinez2022-05-16 21:13:09 -0500
commit7965e514bd886c6f33e4256d3c63209200efb086 (patch)
tree7a675ccba73fc566555e9d2d6d1ef29cd3d20988
parent82776042af8e252b9c6eec5578ba173637b18b46 (diff)
downloadaur-python-bugsnag.tar.gz
update to 4.2.1
-rw-r--r--.SRCINFO4
-rw-r--r--CHANGELOG.md7
-rw-r--r--PKGBUILD16
3 files changed, 18 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eacdb7690899..62fda7bf0505 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-bugsnag
pkgdesc = Official bugsnag error monitoring and error reporting for various python apps.
- pkgver = 4.2.0
+ pkgver = 4.2.1
pkgrel = 1
url = https://github.com/bugsnag/bugsnag-python
changelog = CHANGELOG.md
@@ -13,7 +13,7 @@ pkgbase = python-bugsnag
depends = python-webob
optdepends = python-flask: Flask integration
optdepends = python-blinker: Flask integration
- source = python-bugsnag-4.2.0.tar.gz::https://github.com/bugsnag/bugsnag-python/archive/v4.2.0.tar.gz
+ source = python-bugsnag-4.2.1.tar.gz::https://files.pythonhosted.org/packages/source/b/bugsnag/bugsnag-4.2.1.tar.gz
sha256sums = c8bf852972054deed2026866c4b7b6cc6c64ae306b370c885ecf4995a72f5897
pkgname = python-bugsnag
diff --git a/CHANGELOG.md b/CHANGELOG.md
index b8c592659199..63ec5137c806 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,6 +1,13 @@
Changelog
=========
+## v4.2.1 (2022-05-16)
+
+### Bug fixes
+
+* Apply `params_filters` to URLs in request metadata
+ [#318](https://github.com/bugsnag/bugsnag-python/pull/318)
+
## v4.2.0 (2022-02-18)
### Enhancements
diff --git a/PKGBUILD b/PKGBUILD
index 093a611d4fc5..4eb5e3a898eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Batuhan Baserdem <lastname dot firstname at gmail>
pkgname=python-bugsnag
-pkgver=4.2.0
+pkgver=4.2.1
pkgrel=1
pkgdesc='Official bugsnag error monitoring and error reporting for various python apps.'
arch=('any')
@@ -15,17 +15,19 @@ optdepends=(
makedepends=('python-setuptools' 'python-build' 'python-installer' 'python-wheel')
changelog=CHANGELOG.md
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('c8bf852972054deed2026866c4b7b6cc6c64ae306b370c885ecf4995a72f5897')
+sha256sums=('c7a6dcf013a6e942dd48abc86b7296117c52b4309b99ea7ee066281f76489330')
build() {
cd "bugsnag-python-$pkgver"
- python -m build --wheel --skip-dependency-check --no-isolation
+ python -m build --wheel --no-isolation
}
package() {
- export PYTHONHASHSEED=0
cd "bugsnag-python-$pkgver"
- python -m installer --destdir="$pkgdir/" dist/*.whl
- install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -Dm644 UPGRADING.md -t "$pkgdir/usr/share/doc/$pkgname/"
+ PYTHONHASHSEED=0 python -m installer --destdir="$pkgdir/" dist/*.whl
+ local _site="$(python -c 'import site; print(site.getsitepackages()[0])')"
+ install -d "$pkgdir/usr/share/licenses/$pkgname/"
+ ln -s \
+ "$_site/bugsnag-$pkgver.dist-info/LICENSE.txt" \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}