summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2024-04-29 08:20:54 +0000
committerxiota2024-04-29 08:21:11 +0000
commit3227545bb6cb4c7196f67595b8d8f6fba8e416a8 (patch)
treea524cc8838ed67b35d752fac69ba9e8f02e00ea0
parentc72683861ea29730b4d00883037acf179b505697 (diff)
downloadaur-python-cairo-git.tar.gz
1.26.0.r1
The maintainer/contributor list was reset because this package had to be rewritten.
-rw-r--r--.SRCINFO30
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD115
3 files changed, 55 insertions, 94 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 16c9a6d438d2..f9ed47596ab0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,18 @@
pkgbase = python-cairo-git
- pkgdesc = Python bindings for the cairo graphics library. Git version.
- pkgver = 1.25.0.r21.ge44fe88
- pkgrel = 2
- url = http://www.cairographics.org/
- arch = arm
- arch = armv7h
- arch = aarch64
- arch = powerpc
- arch = i686
+ pkgdesc = Python bindings for the cairo graphics library
+ pkgver = 1.26.0.r1.gda92fff
+ pkgrel = 1
+ url = https://github.com/pygobject/pycairo
arch = x86_64
- license = LGPL3
+ license = LGPL-2.1-only
+ checkdepends = python-pytest
makedepends = git
- makedepends = pkg-config
- makedepends = python-setuptools
+ makedepends = meson
+ makedepends = python-sphinx
+ makedepends = python-sphinx_rtd_theme
+ depends = cairo
depends = python
- depends = cairo>=1.12
- provides = python-cairo=1.20.0
- provides = pycairo=1.20.0
- conflicts = python-cairo
- conflicts = pycairo
- options = !libtool
- source = python-cairo::git+https://github.com/pygobject/pycairo
+ source = python-cairo::git+https://github.com/pygobject/pycairo.git
sha256sums = SKIP
pkgname = python-cairo-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index 228d89bd980b..aa15230c49f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,84 +1,49 @@
-# Maintainer: Frederic Bezies <fredbezies at gmail dot com>
-# Old Maintainer:Lubosz Sarnecki <lubosz@gmail.com>
-# Old Maintainer: Karol "Kenji Takahashi" Woźniak <kenji.sx>
-# Contributor: Pellegrino Prevete <pellegrinoprevete@gmail.com>
-# Contributor: Truocolo <truocolo@aol.com>
+# Maintainer:
+
+_pkgname="python-cairo"
+pkgname="$_pkgname-git"
+pkgver=1.26.0.r1.gda92fff
+pkgrel=1
+pkgdesc="Python bindings for the cairo graphics library"
+url="https://github.com/pygobject/pycairo"
+license=('LGPL-2.1-only')
+arch=('x86_64')
-_py=python
-_pkg=cairo
-_Pkg="py${_pkg}"
-_pkgname="${_py}-${_pkg}"
-pkgname="${_py}-${_pkg}-git"
-pkgver=1.25.0.r21.ge44fe88
-pkgrel=2
-pkgdesc="Python bindings for the cairo graphics library. Git version."
-url="http://www.${_pkg}graphics.org/"
-_ns="pygobject"
-_url="https://github.com/${_ns}/${_Pkg}"
-arch=(
- 'arm'
- 'armv7h'
- 'aarch64'
- 'powerpc'
- 'i686'
- 'x86_64')
-license=(
- 'LGPL3')
depends=(
- "${_py}"
- "${_pkg}>=1.12")
+ 'cairo'
+ 'python'
+)
makedepends=(
'git'
- 'pkg-config'
- "${_py}-setuptools")
-options=(
- '!libtool')
-provides=(
- "${_pkgname}=1.20.0"
- "${_Pkg}=1.20.0")
-conflicts=(
- "${_pkgname}"
- "${_Pkg}")
-source=(
- "${_pkgname}::git+${_url}")
-sha256sums=(
- 'SKIP')
-
+ 'meson'
+ 'python-sphinx'
+ 'python-sphinx_rtd_theme'
+)
+checkdepends=('python-pytest')
+
+_pkgsrc="$_pkgname"
+source=("$_pkgsrc"::"git+https://github.com/pygobject/pycairo.git")
+sha256sums=('SKIP')
+
pkgver() {
- cd \
- "${srcdir}/${_pkgname}"
- git \
- describe \
- --long \
- --tags | \
- sed \
- 's/\([^-]*-g\)/r\1/;s/-/./g' | \
- cut \
- -c2-48
+ cd "$_pkgsrc"
+ git describe --long --tags --abbrev=7 \
+ | sed -E 's/^[^0-9]*//;s/([^-]*-g)/r\1/;s/-/./g'
}
-
-package() {
- cd \
- "${srcdir}/${_pkgname}"
- local \
- _cflags=()
- _cflags=(
- "-I$( \
- dirname \
- "$(cc \
- -v 2>&1 |
- grep \
- "InstalledDir" | \
- awk '{print $2}')")/include/cairo"
- "${CFLAGS}"
- )
- CFLAGS="${_cflags[*]}" \
- "${_py}" \
- setup.py \
- install \
- --root="${pkgdir}" \
- --optimize=1
+
+build() {
+ arch-meson "$_pkgsrc" build
+ meson compile -C build
}
-# vim:set sw=2 sts=-1 et:
+check() {
+ meson test -C build --print-errorlogs
+}
+
+package() {
+ meson install -C build --destdir="$pkgdir"
+ # compile Python bytecode
+ python -m compileall -d /usr/lib "$pkgdir/usr/lib"
+ python -O -m compileall -d /usr/lib "$pkgdir/usr/lib"
+}