summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2024-01-06 09:49:19 -0700
committerMark Wagie2024-01-06 09:49:19 -0700
commit4a6a19f7cba37fbb0127ccba73f3fec169ea8cd3 (patch)
tree480872a29f0a4ce5cc7fc755bc8abb5b6f369c29
parent4b9dc253aa25f8d16a30a7780e2a61d143d52d49 (diff)
downloadaur-4a6a19f7cba37fbb0127ccba73f3fec169ea8cd3.tar.gz
disable pytest warnings
-rw-r--r--PKGBUILD26
1 files changed, 21 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 20aa7152591c..07e012e72d45 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,10 +9,26 @@ pkgdesc="A CalDAV (RFC4791) client library for Python"
arch=('any')
url="https://github.com/python-caldav/caldav"
license=('Apache' 'GPL3')
-depends=('python-icalendar' 'python-lxml' 'python-recurring-ical-events'
- 'python-requests' 'python-six' 'python-tzlocal' 'python-vobject')
-makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
-checkdepends=('python-pytest-cov' 'radicale' 'xandikos')
+depends=(
+ 'python-icalendar'
+ 'python-lxml'
+ 'python-recurring-ical-events'
+ 'python-requests'
+ 'python-six'
+ 'python-tzlocal'
+ 'python-vobject'
+)
+makedepends=(
+ 'python-build'
+ 'python-installer'
+ 'python-setuptools'
+ 'python-wheel'
+)
+checkdepends=(
+ 'python-pytest-cov'
+ 'radicale'
+ 'xandikos'
+)
source=("${_name}-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
sha256sums=('b733fb9e038e1addf725ad3bb8ec8725d6f4f401cc7203ef01936faa618f5409')
@@ -23,7 +39,7 @@ build() {
check() {
cd "${_name}-$pkgver"
- pytest
+ pytest -p no:warnings
}
package() {