summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuís Ferreira2019-06-30 21:41:06 +0100
committerLuís Ferreira2019-06-30 21:41:06 +0100
commit24df398fedcab9132e2b6982925b57071892a9a1 (patch)
treec0e17cc6a42037db722158332d3bdc71ae6f89a3
parentd5c91baafe64ab739a20e9697b62c35e948950ba (diff)
downloadaur-python-catkin.tar.gz
pkg: update to version 0.4.12-2
Signed-off-by: Luís Ferreira <contact@lsferreira.net>
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD5
2 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 34bc4670216d..9100d0720837 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-catkin
pkgdesc = catkin package library
pkgver = 0.4.12
- pkgrel = 1
+ pkgrel = 2
url = http://wiki.ros.org/catkin_pkg
arch = any
license = BSD
@@ -27,9 +27,6 @@ pkgbase = python-catkin
makedepends = python2-dateutil
makedepends = python-docutils
makedepends = python2-docutils
- conflicts = python2-catkin_pkg
- conflicts = python-catkin-pkg
- conflicts = python-catkin_pkg
source = https://github.com/ros-infrastructure/catkin_pkg/archive/0.4.12.tar.gz
sha256sums = cc2f4f4c02aa72d3b1fad18fe87348ac009c4b9da5602a09cd954a287d330e4e
@@ -39,6 +36,8 @@ pkgname = python-catkin
depends = python-dateutil
depends = python-docutils
depends = python-pyparsing
+ provides = python-catkin-pkg
+ provides = python-catkin_pkg
pkgname = python2-catkin
depends = python2
@@ -46,4 +45,5 @@ pkgname = python2-catkin
depends = python2-dateutil
depends = python2-docutils
depends = python2-pyparsing
+ provides = python2-catkin_pkg
diff --git a/PKGBUILD b/PKGBUILD
index 8cc4e9662164..2fd44a608a48 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,12 +5,11 @@ pkgbase='python-catkin'
pkgname=('python-catkin' 'python2-catkin')
_module='catkin_pkg'
pkgver='0.4.12'
-pkgrel=1
+pkgrel=2
pkgdesc="catkin package library"
url="http://wiki.ros.org/catkin_pkg"
arch=('any')
license=('BSD')
-conflicts=('python2-catkin_pkg' 'python-catkin-pkg' 'python-catkin_pkg')
makedepends=(
'python' 'python2'
'python-setuptools' 'python2-setuptools'
@@ -48,6 +47,7 @@ package_python2-catkin() {
'python2-docutils'
'python2-pyparsing'
)
+ provides=('python2-catkin_pkg')
cd "${srcdir}/${_module}-${pkgver}"
@@ -63,6 +63,7 @@ package_python-catkin() {
'python-docutils'
'python-pyparsing'
)
+ provides=('python-catkin-pkg' 'python-catkin_pkg')
cd "${srcdir}/${_module}-${pkgver}"