summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLoen2016-06-24 07:48:08 +0000
committerLoen2016-06-24 07:48:08 +0000
commit5e58ae4db843bbbdc252a6067662d322e0919d9d (patch)
tree41be521f64fbc6e25bc569b4d9d5f4b0ea7408aa
parent3bb95556e3d1a69ec7d481fafb4705babc65834e (diff)
downloadaur-python-cli.tar.gz
First Loen commit
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD17
2 files changed, 13 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a5cf4e81d625..51f32260a495 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = python-cli
pkgdesc = A framework for making simple, correct command line applications in Python. Also known as pyCLI.
pkgver = 2.0.3
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/whilp/cli
arch = any
license = custom:ISC
- makedepends = python-setuptools
+ makedepends = python-pip
+ makedepends = python2-pip
depends = python
source = https://github.com/whilp/cli/archive/v2.0.3.tar.gz
sha256sums = 66e54c2bb5e31f6d306679efe3297b020c14ce487e57e6a4bfac3f58033f782a
diff --git a/PKGBUILD b/PKGBUILD
index 5fc95e2916a1..15f65aefae9d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,20 @@
-# Maintainer: Andrejs Mivreņiks <gim at fastmail dot fm>
-pkgname=python-cli
-pkgver=2.0.3
-pkgrel=2
+# Maintainer: Andrejs Mivre??iks <gim at fastmail dot fm>
+pkgname='python-cli'
+pkgver='2.0.3'
+pkgrel=3
pkgdesc='A framework for making simple, correct command line applications in Python. Also known as pyCLI.'
arch=('any')
url='https://github.com/whilp/cli'
license=('custom:ISC')
depends=('python')
-makedepends=('python-setuptools')
-source=("https://github.com/whilp/cli/archive/v${pkgver}.tar.gz")
+makedepends=('python-pip' 'python2-pip')
+source=("https://github.com/whilp/cli/archive/v2.0.3.tar.gz")
sha256sums=('66e54c2bb5e31f6d306679efe3297b020c14ce487e57e6a4bfac3f58033f782a')
package() {
cd "${srcdir}/cli-$pkgver"
- python setup.py install --root=$pkgdir --prefix=/usr --optimize=1
+ echo :: Installing for python3.5 ...
+ pip3 install --isolated --root="${pkgdir}" --no-deps --ignore-installed .
+ echo :: Installing for python2.7 ...
+ pip2 install --isolated --root="${pkgdir}" --no-deps --ignore-installed .
}