summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCayetano Santos2021-06-01 01:06:31 +0200
committerCayetano Santos2021-06-01 01:06:31 +0200
commit2ec3dd38154dd5fb63517a675e062dcdb133b416 (patch)
treea1e8bba65831f1ebb26603d50168ac9dd257cae2
parent1af9edc30c80dd113b94e7ac393cc7023f4fc849 (diff)
downloadaur-2ec3dd38154dd5fb63517a675e062dcdb133b416.tar.gz
CI: include resulting package as an artifact
-rw-r--r--.SRCINFO3
-rw-r--r--.gitlab-ci.yml5
-rw-r--r--PKGBUILD1
3 files changed, 4 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0b892986ad04..486f187fcebc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,9 +5,6 @@ pkgbase = python-cocotb
url = http://github.com/cocotb/cocotb/
arch = any
license = BSD
- makedepends = git
- makedepends = gcc
- makedepends = python-pip
depends = python
depends = python-setuptools
optdepends = iverilog: for simulating verilog designs
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
index df3c5cab1b7e..b38dd3f3d53a 100644
--- a/.gitlab-ci.yml
+++ b/.gitlab-ci.yml
@@ -10,7 +10,7 @@ stages:
before_script:
- pacman --noconfirm -Syu
- - pacman --noconfirm -S sudo git fakeroot binutils
+ - pacman --noconfirm -S sudo gcc fakeroot binutils
- useradd -m notroot
- echo "$DOSUDO" > /etc/sudoers.d/notroot
@@ -21,3 +21,6 @@ build-package:
script:
- su notroot -c "makepkg --noconfirm --syncdeps --rmdeps --install --clean"
- python -c 'import cocotb; print("All OK")'
+ artifacts:
+ paths:
+ - python-cocotb-1.5-2-any.pkg.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
index 6afd3c6c7a5f..dffc150ba9cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,6 @@ url="http://github.com/cocotb/cocotb/"
license=('BSD')
depends=('python' 'python-setuptools')
-makedepends=('git' 'gcc' 'python-pip')
optdepends=('iverilog: for simulating verilog designs'
'ghdl: for simulating VHDL designs'
'gtkwave: for visualizing waveforms')