summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCayetano Santos2020-03-21 12:19:49 +0100
committerCayetano Santos2020-03-21 12:19:49 +0100
commit3594d82be7d2469ff9d126dd4673306745384de6 (patch)
tree4185aff7f4ad6a837eddb97589cdf28918953a1c
parent2006eeb20bb5d6a7564e1f3ec5c66b7437e7b770 (diff)
downloadaur-3594d82be7d2469ff9d126dd4673306745384de6.tar.gz
independent repo python-cocotb
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD21
-rw-r--r--cocotb.install18
3 files changed, 23 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2ed2372db104..9a920ac3b80b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,21 @@
-pkgbase = cocotb
+pkgbase = python-cocotb
pkgdesc = Coroutine based cosimulation library for writing VHDL and Verilog testbenches in Python
pkgver = 1.3
- pkgrel = 0
- epoch = 0
+ pkgrel = 1
url = http://github.com/cocotb/cocotb/
- install = cocotb.install
- arch = x86_64
+ arch = any
license = BSD
+ makedepends = git
+ makedepends = python-setuptools
depends = python
optdepends = iverilog: for simulating verilog designs
optdepends = ghdl: for simulating VHDL designs
optdepends = gtkwave: for visualizing waveforms
- provides = cocotb
- conflicts = cocotb
- source = https://github.com/cocotb/cocotb/archive/v1.3.0.tar.gz
- md5sums = 4db3d270943da293cf4dd7ce22594307
+ provides = python-cocotb
+ conflicts = python-cocotb
+ options = !emptydirs
+ source = git+https://github.com/cocotb/cocotb#tag=v1.3.1
+ md5sums = SKIP
+
+pkgname = python-cocotb
-pkgname = cocotb
diff --git a/PKGBUILD b/PKGBUILD
index a2c2108c6baa..957aac432446 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,26 @@
-# Maintainer: mox <demox@lavabit.com>
-pkgname=cocotb
+# Maintainer: csantosb <csantosb dot inventati dot org>
+pkgname=python-cocotb
pkgver=1.3
pkgrel=1
-epoch=0
pkgdesc="Coroutine based cosimulation library for writing VHDL and Verilog testbenches in Python"
-arch=('x86_64') # Can probably support other architectures as well, try your luck?
+arch=('any')
url="http://github.com/cocotb/cocotb/"
license=('BSD')
-conflicts=('cocotb')
-provides=('cocotb')
+conflicts=('python-cocotb')
+provides=('python-cocotb')
depends=('python')
+
+makedepends=('git' 'python-setuptools')
optdepends=('iverilog: for simulating verilog designs'
'ghdl: for simulating VHDL designs'
'gtkwave: for visualizing waveforms')
-install=${pkgname}.install
-source=("https://github.com/cocotb/$pkgname/archive/v$pkgver.$pkgrel.tar.gz")
-md5sums=('0d9dd62350649c91c9a4fa202ad20dda')
+options=(!emptydirs)
+source=("git+https://github.com/cocotb/cocotb#tag=v${pkgver}.${pkgrel}")
+md5sums=('SKIP')
package() {
- cd "${srcdir}/cocotb-$pkgver.$pkgrel"
+ cd "${srcdir}/cocotb"
python setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1
install -m 644 -D ./LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
}
diff --git a/cocotb.install b/cocotb.install
deleted file mode 100644
index 7ffdc15635bf..000000000000
--- a/cocotb.install
+++ /dev/null
@@ -1,18 +0,0 @@
-post_install() {
- echo ''
- echo ''
- echo 'cocotb relies on some environment variables.'
- echo ' You need to set COCOTB="/usr/local/cocotb-1.1.0"'
- echo ''
- echo 'A simple Makefile could look like this:'
- echo '--------------------------------------------------------------------------------'
- echo 'export USER_DIR:=$(shell pwd) # Without this cocotb will try to build in /usr/local...'
- echo 'include $(COCOTB)/makefiles/Makefile.inc'
- echo 'include $(COCOTB)/makefiles/Makefile.sim'
- echo 'VERILOG_SOURCES = my_example.sv'
- echo 'TOPLEVEL = my_example'
- echo 'MODULE=test_my_example'
- echo '--------------------------------------------------------------------------------'
- echo ''
- echo ''
-}