summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCayetano Santos2020-03-08 12:38:47 +0100
committerCayetano Santos2020-03-08 12:38:47 +0100
commit685b15e4e8ab1e6f38f8edeb0aa73b1fa29d1f11 (patch)
treeff66bbf1f1f63eb43d488d50e51619f278a3a8f5
parente04f12316b4e58547a534675e709b947c0b76d01 (diff)
downloadaur-685b15e4e8ab1e6f38f8edeb0aa73b1fa29d1f11.tar.gz
Update package function
-rw-r--r--PKGBUILD10
1 files changed, 3 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b25df179d6a3..ec4d4d0a36e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -30,11 +30,7 @@ md5sums=('4db3d270943da293cf4dd7ce22594307')
#}
package() {
- cd "$pkgname-$pkgver"
-
- make INSTALL_DIR="$pkgdir/usr/local" install
- rm -r "$pkgdir/usr/local/cocotb-1.1.0/bin"
-
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "${srcdir}/cocotb"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE
}
-