summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCayetano Santos2020-03-08 20:14:48 +0100
committerCayetano Santos2020-03-08 20:14:48 +0100
commit705199ade796951453d7b8269da7f397f52badf8 (patch)
tree2a8d286e3a1da53b8d96ed8ef898c33d11af0c22
parent5cb1897f5a525b7654040d6221cf9e0c3f4d44a1 (diff)
downloadaur-705199ade796951453d7b8269da7f397f52badf8.tar.gz
Fixes and cleanup
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD25
2 files changed, 10 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb6a95507f0a..2ed2372db104 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,13 +7,13 @@ pkgbase = cocotb
install = cocotb.install
arch = x86_64
license = BSD
- makedepends = git
- makedepends = python-setuptools
depends = python
optdepends = iverilog: for simulating verilog designs
optdepends = ghdl: for simulating VHDL designs
+ optdepends = gtkwave: for visualizing waveforms
+ provides = cocotb
+ conflicts = cocotb
source = https://github.com/cocotb/cocotb/archive/v1.3.0.tar.gz
md5sums = 4db3d270943da293cf4dd7ce22594307
pkgname = cocotb
-
diff --git a/PKGBUILD b/PKGBUILD
index 71e22c08b12b..154ea26c814a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,30 +7,19 @@ pkgdesc="Coroutine based cosimulation library for writing VHDL and Verilog testb
arch=('x86_64') # Can probably support other architectures as well, try your luck?
url="http://github.com/cocotb/cocotb/"
license=('BSD')
-#groups=()
+conflicts=('cocotb')
+provides=('cocotb')
depends=('python')
-makedepends=('git' 'python-setuptools')
-#checkdepends=()
-optdepends=('iverilog: for simulating verilog designs' 'ghdl: for simulating VHDL designs')
-#provides=()
-#conflicts=()
-#replaces=()
-#backup=()
-#options=()
+optdepends=('iverilog: for simulating verilog designs'
+ 'ghdl: for simulating VHDL designs'
+ 'gtkwave: for visualizing waveforms')
+
install=${pkgname}.install
-#changelog=
source=("https://github.com/cocotb/$pkgname/archive/v$pkgver.$pkgrel.tar.gz")
md5sums=('4db3d270943da293cf4dd7ce22594307')
-#validpgpkeys=()
-
-
-#check() {
-# cd "$pkgname-$pkgver"
-# make test # currently fails, see https://github.com/potentialventures/cocotb/issues/833
-#}
package() {
- cd "${srcdir}/cocotb"
+ cd "${srcdir}/cocotb-$pkgver.$pkgrel"
python setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1
install -m 644 -D ./LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
}