summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2023-05-21 21:51:27 -0500
committerCarlos Aznarán Laos2023-05-21 21:51:27 -0500
commit861505e2c0e6b55d2f9bf3351e7c6a46147cd504 (patch)
tree3a1af1ee280ca1c558e8e3c6aaa636d981e661ab
parent5dce167eb42ffa9b76f8ae68d199cc23e05da9cb (diff)
downloadaur-python-codepy.tar.gz
Bump version to 2023.1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD34
2 files changed, 25 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 429a37886745..e5cfa5490b82 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,18 @@
pkgbase = python-codepy
- pkgdesc = Generate and execute native code at run time, from Python
- pkgver = 2019.1
- pkgrel = 4
+ pkgdesc = Generate and execute native code at run time
+ pkgver = 2023.1
+ pkgrel = 1
url = https://documen.tician.de/codepy
arch = x86_64
license = MIT
checkdepends = python-pytest
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
- makedepends = git
- depends = python-six
- depends = python-appdirs
+ makedepends = python-wheel
depends = python-cgen
depends = boost
- source = git+https://github.com/inducer/codepy.git?signed#tag=v2019.1
- validpgpkeys = 900A958D9A0ACA58B1468F2471AA298BCA171145
- sha512sums = SKIP
+ source = https://pypi.org/packages/source/c/codepy/codepy-2023.1.tar.gz
+ sha512sums = ebc4e6a5e9747176d1ef6e254efe4d81f590ef5486476326383afe133b3b712a38d59d7c9a5cdb576fd19380baa87f9cc9b4874bc051b0f7e70693d8c225406f
pkgname = python-codepy
diff --git a/PKGBUILD b/PKGBUILD
index bdbeedbfd040..7b98614e2335 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,32 @@
# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
_base=codepy
pkgname=python-${_base}
-pkgdesc="Generate and execute native code at run time, from Python"
-pkgver=2019.1
-pkgrel=4
-arch=('x86_64')
+pkgdesc="Generate and execute native code at run time"
+pkgver=2023.1
+pkgrel=1
+arch=(x86_64)
url="https://documen.tician.de/${_base}"
license=(MIT)
-depends=(python-six python-appdirs python-cgen boost)
-makedepends=(python-setuptools git)
+depends=(python-cgen boost)
+makedepends=(python-build python-installer python-setuptools python-wheel)
checkdepends=(python-pytest)
-source=("git+https://github.com/inducer/${_base}.git?signed#tag=v${pkgver}")
-validpgpkeys=("900A958D9A0ACA58B1468F2471AA298BCA171145") # Andreas Kloeckner
-sha512sums=('SKIP')
+source=(https://pypi.org/packages/source/${_base::1}/${_base}/${_base}-${pkgver}.tar.gz)
+sha512sums=('ebc4e6a5e9747176d1ef6e254efe4d81f590ef5486476326383afe133b3b712a38d59d7c9a5cdb576fd19380baa87f9cc9b4874bc051b0f7e70693d8c225406f')
build() {
- cd "${_base}"
- python setup.py build
+ cd ${_base}-${pkgver}
+ python -m build --wheel --skip-dependency-check --no-isolation
}
check() {
- cd "${_base}"
- PYTHONPATH="$PWD/build/lib/${_base}/" python -m pytest
+ cd ${_base}-${pkgver}
+ python -m venv --system-site-packages test-env
+ test-env/bin/python -m installer dist/*.whl
+ test-env/bin/python -m pytest
}
package() {
- cd "${_base}"
- export PYTHONHASHSEED=0
- PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
- # install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ cd ${_base}-${pkgver}
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}